Pls help - rclone zoho drive japan region setup problem

What is the problem you are having with rclone?

Zoho WorkDrive - no japan region option for rclone config , when choosing default options, the browser said "Invalid Client , Client ID passed does not exist"

Run the command 'rclone version' and share the full output of the command.

~ $ rclone version
rclone v1.59.0-beta.6116.1d6d41fb9

  • os/version: raspbian 10.12
  • os/kernel: 5.10.103-v7l+ (armv7l)
  • os/type: linux
  • os/arch: arm
  • go/version: go1.18.1
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Zoho WorkDrive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

no problem here

The rclone config contents with secrets removed.

Leave blank normally.
Enter a value. Press Enter to leave empty.
client_id> 
Option client_secret.
OAuth Client Secret.
Leave blank normally.
Enter a value. Press Enter to leave empty.
client_secret> 
Option region.
Zoho region to connect to.
You'll have to use the region your organization is registered in. If
not sure use the same top level domain as you connect to in your
browser.
Choose a number from below, or type in your own value.
Press Enter to leave empty.
 1 / United states / Global
   \ (com)
 2 / Europe
   \ (eu)
 3 / India
   \ (in)
 4 / Australia
   \ (com.au)
region> 1
Edit advanced config?
y) Yes
n) No (default)
y/n> n
Use auto config?
 * Say Y if not sure
 * Say N if you are working on a remote or headless machine

y) Yes (default)
n) No
y/n> y

A log from the command with the -vv flag

DEBUG : rclone: Version "v1.59.0-beta.6116.1d6d41fb9" starting with parameters ["rclone" "-vv"]

Just type in whatever your top level domain is so "jp" I'd guess for Japan.

Not work... still showing the error "Invalid Client
Client ID passed does not exist"

You'd have to share some output and steps you have done.

Did you setup your own client ID in https://api-console.zoho.com/ ?

What did you type in for the region? What does your browser show as the region?

do it and still not work ..
however, the zoho platform show different message:

Invalid Redirect Uri
Redirect URI passed does not match with the one configured

If you can't share the steps, logs and screenshots, we can't figure out what's going on.

You do not want to type in 1 for the region.

You want to type in "jp" as that matches your region in your browser.

I do it once again with 'jp" setting"

Instead of screenshots, can you please post text. it's cut off and I can't see part of the screen.

Use three back tics "`" above and below the text like

this here

So it shows up as I need the full text from you hit "Y"

Also, can you share the screenshot of what you did configuring the API client ID/secret?

The redirect URI should look something like:

Which looks to be wrong in your configuration.

I did this for all regions so not sure what you did:

thx and seems still not work...
btw I will ask for zoho team to trouble shoot..
thx for the help

Without seeing what you got, there isn't much they can do either. If you can share the details I'm asking, we can probably figure out what's going on...

just finally do some testing and get the solution.
Just change the http://127.0.0.1:53682/ to http://localhost:53682/
The oauthv2 call back work again.

Neat. We should update the docs as well as that's a good find.

I validated that as well and that's a strange one!

1 Like

I logged a doc fix for it:

Potential Doc Fix for Zoho · Issue #6163 · rclone/rclone (github.com)

1 Like