Plex seeking slow until it reads till --vfs-read-ahead

What is the problem you are having with rclone?

A WebDAV mount with rclone. I have a 100mbit/s internet, and I'm trying to mount a remote directory to smoothly playback high bitrate files. The files average 60mbit/s but can peak at 120mbit/s. My wish is to use vfs cache read ahead to maximise my internet use so that I have a smoother playback experience during the bumpy parts.

This struggles until a significant part of the cache is read ahead. If I reduce --vfs-read-ahead to 32M then it can play in a few seconds. It also plays fine if I turn VFS cache off.

Run the command 'rclone version' and share the full output of the command.

rclone v1.66.0
- os/version: Microsoft Windows 11 Pro 23H2 (64 bit)
- os/kernel: 10.0.22631.3374 (x86_64)
- os/type: windows
- os/arch: amd64
- go/version: go1.22.1
- go/linking: static
- go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

A custom seedbox hosted with ultra.cc in Singapore running a WebDAV server

The command you were trying to run (eg rclone copy /tmp remote:tmp)

./rclone mount Palawan:/Downloads X: --read-only -v --vfs-cache-mode full --vfs-read-ahead 8G --vfs-fast-fingerprint --no-checksum --no-modtime --vfs-cache-max-size 100G --vfs-cache-max-age 3d -vv --log-file=tmp3.txt

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

[Palawan]
type = webdav
url = https://dragooon.palawan.usbx.me/nextcloud/remote.php/dav/files/nextcloud
vendor = nextcloud
user = XXX
pass = XXX

A log from the command that you were trying to run with the -vv flag

Log when using VFS cache: log-vfs-cache ยท GitHub

Log when using VFS cache with read-ahead set to 8M: