Plex performance when seek

#1

Hello,

I'm currently having issues with extremely slow seek speed when trying to resume a playback or to move forward or backward while running it.

I've noticed Rate Limit Exceeded errors while starting the files but I couldn't fix it with my config shown below (using my own API):

2019/05/12 13:43:34 DEBUG : pacer: Rate limited, sleeping for 1.072383202s (1 consecutive low level retries)
2019/05/12 13:43:34 DEBUG : pacer: low level retry 1/10 (error googleapi: Error 403: Rate Limit Exceeded, rateLimitExce$
2019/05/12 13:43:34 DEBUG : pacer: Rate limited, sleeping for 2.815143225s (2 consecutive low level retries)
2019/05/12 13:43:34 DEBUG : pacer: low level retry 2/10 (error googleapi: Error 403: Rate Limit Exceeded, rateLimitExce$
2019/05/12 13:43:35 DEBUG : pacer: Rate limited, sleeping for 4.244254584s (3 consecutive low level retries)
2019/05/12 13:43:35 DEBUG : pacer: low level retry 3/10 (error googleapi: Error 403: Rate Limit Exceeded, rateLimitExce$
2019/05/12 13:43:39 DEBUG : pacer: Resetting sleep to minimum 10ms on success

Here is the config I'm using:

ExecStart=/usr/bin/rclone mount \
  --log-file ${LOGS}/rclone.log \
  --log-level=DEBUG \
  --dir-cache-time=96h \
  --vfs-read-chunk-size=128M \
  --vfs-read-chunk-size-limit=off \
  --vfs-cache-mode=writes \
  --drive-chunk-size=32M \
  --buffer-size=64M \
  --timeout=1h \
  --umask=002 \
  --allow-other \
  --bwlimit=60M \
  --checkers=3 \
  --tpslimit=3 \
  --cache-dir ${UPLOADS} \
  --config ${RCLONEHOME}/rclone.conf \

Would anyone know how I can improve start time and seek/resume speeds with that setup?

Thanks.

#2

You need to use your own API key / Client ID:

https://rclone.org/drive/#making-your-own-client-id

Make sure you are on the latest version.
Checkers does nothing on a mount so it can be removed.
No reason for a tpslimit on a mount.

While you mention you are using your own key, it doesn't seem to be configured. You'd have to share your rclone.conf and you'd want to validate it actually is using it.

#3

Here is how the rclone.conf looks. Just tried to auth again but I can't see the secret ID or client secret there:

[gdrive]
    type = drive
    scope = drive
    token = {"access_token":"ya29.Gl0HBw-k7ym3zdOP6olITXpPte********54QRZCTI64crelgfMYIbB_vlHRXEJRaht4P********OEVXoiKSue2gncBdCeKoYqr2_7a9aQZg21ATt74nJsKcoNFcMk","token_type":"Bearer","refresh_token":"1/5zc8sqeD55V0bV1jp1gbq*********_i0prtai0prtaJoOCxN0","expiry":"2019-05-12T18:20:01.804558536+02:00"}
#4

You need to follow the steps as you should have a client ID and client secret. Those are missing from your conf so you are using the default key, which is why you see the 403 rate limits.

Looks like:

image

#5

Hey,

When you mentioned that these are missing I just realized that the conf file goes to /root/.config/rclone and my mount was looking for .conf for a different user for some reason (/home/username/.config/rclone) so it wasn't using my own API.

Thanks a lot for the help. Seems to be a lot more smooth now. Just last thing as I'm optimizing things, is there a point in using vfs or I can just remove it and use the default settings?

Thanks again.

#6

VFS is the default.

I run a very simple mount and really only make dir-cache time bigger.

#7

Thanks a lot for the help, I can't believe I've been using it like that for months :smiley:

#8

Glad it is working better for you!

1 Like
closed #9

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.