Plex not recognising files inside Rclone mounted Google drive

Hi there,
I am very new to Plex and Rclone as well as Linux so forgive me for my lack of understanding.
I am having difficulty with plex. When I add the google drive which I mounted, Plex does not show the contents of it.

I have heard that it may be an issue with permissions, but can't seem to figure out a fix. Some people have recommended adding flags to the line when I mount the drive but I'm not sure how to do this.
If it helps the command i am using at the moment to mount it is: rclone mount mygoogledrive: ~/drive/

I am using Linux Mint

Thank you very much for your time.

Try adding "--allow-other" flag.

Sorry i have a very basic knowledge of adding flags, would I add it in the mount command line?

Would it then be " rclone mount --allow-other mygoogledrive: ~/drive/ "?

Thank you for help!

yes, that command looks good.

I am getting an error when i use this command.

" mount helper error: fusemount: option allow_other only allowed if 'user_allow_other' is set in /etc/fuse.conf "

how do i fix this?
thank you for the help!

as per the error message,
you need to add or uncomment user_allow_other from the /etc/fuse.conf

Thank you very much for your time,

When i open the fuse.conf it has a line at the bottom which reads #user_allow_other
You said to uncomment this line but I'm not very sure what this means.

Thanks again for the help

remove the # and save the file.

Thank you that link is very helpful.

It is saying i do not have the permission to edit the fuse.conf

Someone said to try sudo addgroup username fuse to try obtain the right permission but this line just gives me an error, addgroup: The group fuse does not exist

to edit the file, run a text editor using sudo
sudo nano /etc/fuse.conf

I cannot thank you enough! It is all working finally!
I learnt a lot from you thank you very much for your time and patience!

glad i could solve your problem

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.