Plex not recognising files in G-Drive Rclone mount

rclone mount gdrive: ~/gdrive
Plex does not list files in the rclone mount but file manager does. Debian VPS, operating via root terminal. Swizzin setup, opted to install Rclone manually but turns out it fails via Swizzin as well.

Tried editing out and enabling the --allow-other from the fuse.conf

Had this exact issue before via another box.

Obviously you are doing something wrong as there are many plex users on this forum without such issue. You have to provide more details in order to investigate.

I mounted using the command, rclone mount gdrive: ~/gdrive after rclone config.

Debian file manager lists the mount, Plex does not recognise files in the folder. What other details can I provide?

Then this is not rclone issue but plex and/or your linux system permissions.

You can create mount open for everybody and everything and it will work:

sudo mkdir /gdrive
sudo chmod 777 /gdrive
rclone mount gdrive: /gdrive --allow-other

Yes linux system permissions definitely sounds like the issue.

/root/gdrive on Plex is still not listing anything. Followed your commands and rebooted.

it is not /root/gdrive but /gdrive

Yes I meant for Plex, which is pointed at /root/gdrive/films. I tried your above commands.

you mount gdrive in /gdrive folder and you expect to see your content in /root/gdrive/ ? These are two different folders

thanks @kaptainsky

No problem - please note that this way:

sudo mkdir /gdrive
sudo chmod 777 /gdrive
rclone mount gdrive: /gdrive --allow-other

is rather proof that issue is with permissions - as pretty much it drops all of them:) Still It might be acceptable on personal server.

Proper way should be to run Plex as user plex and Rclone as user rclone and both belonging to the same group - then folder permissions can be tweaked accordingly - but this is more linux than rclone problem.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.