Plex movie cant continue

What is the problem you are having with rclone?

I setup gdrive and crypt and it all works so far. But when I start a movie or series, and stop watching after 5 minutes, then wait one minute or even less, and I start the same file again, plex can not continue the series, it starts from the beginning. Sometimes plex tries to start from where I left off, but just keeps on loading.There is no encoding, just direct stream/direct play. But I see loads of traffic in plex and nothing is happening.

Run the command 'rclone version' and share the full output of the command.

rclone v1.57.0

  • os/version: ubuntu 20.04 (64 bit)
  • os/kernel: 5.4.0-96-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.17.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Description=RClone Service

ExecStart=/usr/bin/rclone mount gcrypt: /mnt/media \
--log-level=DEBUG \
--config=/home/xx/.config/rclone/rclone.conf \
--allow-other \
--dir-cache-time 5000h \
--log-file /home/xx/services/rclone/logs/rclone.log \
--log-level NOTICE \
--poll-interval 10s \
--umask 002 \
--user-agent xx \
--rc \
--cache-dir=/cache \
--drive-pacer-min-sleep 10ms \
--drive-pacer-burst 200 \
--vfs-cache-mode full \
--vfs-cache-max-size 150G \
--vfs-cache-max-age 5000h \
--vfs-cache-poll-interval 5m \
--vfs-read-ahead 2G \
--bwlimit-file 100M
ExecStop=/bin/fusermount -uz /mnt/media
#ExecStartPost=/usr/bin/rclone rc vfs/refresh recursive=true _async=true


The rclone config contents with secrets removed.

type = drive
client_id = xxx
client_secret = xxx
scope = drive
token = {"access_token":"xx","token_type":"Bearer","refresh_token":"xx","expiry":"2022-01-28T10:03:00.657211513+01:00"}
team_drive = 

type = crypt
remote = gdrive:/encrypted
password = xx
password2 = xx

A log from the command with the -vv flag

I'll add that once I figured out how to get there..

Maybe another Information, I have loads of this errors:

2022/01/28 01:02:43 ERROR : Archiv/XX/YYY (2014)/YYY (2014) - [Unrated 1080p EAC3 x264].mkv: vfs cache: failed to download: vfs reader: failed to write to cache file: unexpected EOF

Change the word "NOTICE" to "DEBUG"

and restart the mount and share the full log.

That usually means the file you have is broken/not uploaded properly but the full debug log would show more.

I'll do that tomorrow, since somehow I ran into an API limit....... And nothing works right now... :frowning:

And as far as I know, these files are fine, since its almost for every file that I have in there.... But we'll see in the logs then.. :wink:

The error log shows the file is not fine though so unless you can share something different, I can only go by what I see.

1 Like

I have one error log for you: 2022/01/28 23:08:29 DEBUG : Archiv/XXX/yyy.mkv: ChunkedReader.Read at 837808128 -
Thats the one for unexpected EOF..

But I actually have an Idea what could be the problem for the "not beeing able to continue watching"
I was scanning (initially) my plex library at the same time as watching this video... could it be, that the scan used so much of my cache, that plex was unable to use a locally cached version of that file?

Nope, I scan / watch / analyze / detect intros all at the same time.

It's meant to handle multiple access patterns.

Is it normal that, when doing the initial scan (abiout 14k movies), I use up all download from gdrive?
My settings have not changed from the one posted above..
I tried to watch a small episode, and this is logged:

The download quota for this file has been exceeded., downloadQuotaExceeded

That means you exceeded your download quota for the day.

Yep, I know, but I was not watching anything... It was just scanning my library...?
I did the same thing two weeks ago with plexdrive, and I dont think I had this issue there.

No idea.

You have 1 line of a snippet of a log so I'm just telling you what that means.

If plexdrive works for you, use it. It really doesn't matter.

I used rclone with GDrive for quite some time with no issues so I'm pretty sure rclone itself is fine as it's probably another setting or something.

Without any details and a 1 line log, that's all I can offer.

Yea.. I understand that... I was just wondering.. I thought that when I use these settings, I should have the same result as everyone else..
And since you used it as well, I was hoping to get an answer to the question.. Like:

"Yes, when scanning your library for the first time, rclone, with theses settings, will download all files from gdrive."

Again, I can't tell you as I've not seen any complete log and only a one line snippets so I have no idea what rclone is doing or not doing.

That could be the case based on a number of things but without a complete debug log to look at, we just use our magic eightball and guess.

We just had this discussion here last week, and many more times before that. What seems to have helped that particular user with his initial scan was adding --vfs-read-chunk-size 1M. Worth a shot, and if it works for you, please report back.

EDIT: Make sure you have intro/chapter detection and everything else that's unnecessary disabled in Plex.

Can I send you the complete log in private?

I stoped plex, stoped the rclone service, deleted the log, created an empty log file, started rclone with commandline parameters, started plex, and klicked on a episode I was watching 3 hours before. Then it started from the beginning, not at 18:something. Then I stoped the episode, and stoped rclone with ctrl+c.
Thats all in the logfile... And its 41.000 lines......

I actually had intro detection on.. But I was only scanning Movies, not TV... The complete scan is now finished.. So everything is fine regarding the scan... Now only the other issue is bugging me :confused:

Could you remind us what that other issue is?

Yes, off course...
I start a media file, stop it any time (in the last example after 18 minutes) and wan to continue later that day or maybe even the next weekend.. But it does not continue, it starts from the beginning, if it loads at all.

That sounds like a Plex issue to me, one that I've encountered myself (SHIELD), although very rarely. When this happens to you, does your client save the playback position?

It happens on any device.. Shield, PC, Smarphone, web.
And yes, the position has been save before, and I see 600mbits of download in plex once I klick play..