Plex library optimize - Gdrive


#41

I’m very well versed regarding Plex and encoding, but I appreciate the resource. Plexus enforces level 4.1 by default (currently non-modifiable). Are both the video and audio streams being transcoded? Or is it just one or the other? While you did set the remote video quality to original, did you actually enable direct play? Have you tried using Plexus v0.9.31 and setting the container to MP4 to see whether it makes a difference?


#42

Well, actually, the try of yesterday night was with file encoded yesterday morning with version:
=== Plexus v0.9.2 - Developed by Robert Thomas ===
Then i didn’t have time to try other encodes or plexus updates.
I will try now with latest update, but i don’t know if i can test on my ATV4 before tonight.

About what is it transcoded i’m sorry, but i don’t know. How can i see it in plex logs?

About enabling direct play on ATV yes.


#43

Can i give a suggestion?

When you ask to type something i think sould be better to have a list of possibilities because now i tried to set mp4 container, but i don’t know how.

Enter the desired codec:
1. Audio
2. Container
3. Video
0. Exit

2

Enter the desired media container: mp4

You have not entered a supported container.


You have not entered a supported container.
MP4

You have not entered a supported container.

#44

When the media is being played, login as the Plex admin and check the Now Playing tab. Hover over the object and it’ll tell you what’s happening…how do you know that it’s being transcoded?

You are correct with how you’re doing it…weird. I’ve just tested it too with the same results. Every other supported container works fine, but not mp4. I’ll see what I can do. A list of possibilities has always been avoided as the list would usually end up being relatively large.

EDIT: Looks like I’ve found the issue. Weird one! I’ll update it in a sec. In the meantime, either enter mp4 twice, or manually modify your config file.


#45

Plexus v0.9.32 has been released. This fixes the config function for both the container and video codecs.


#46

Yes, this is how i saw it was not direct playing but i don’t remember what it was transcoding. And now i’m not at home to try, but i can connect via putty to my server. So if there is a way to look at the log i can answer now to your question.


#47

It’s cool, just try playing it again later and take a screenshot :slight_smile: I know that the defaults set in Plexus are generally the most universal settings you can have (as has been tested by a lot of people now), so I’m inclined to believe that the issue is either with the server configuration or client configuration.


#48

ok, now i will try to encode with mp4 and try both versions mp4 and old mkv


#49

Sorry to bother you, but i don’t know why creating list yesterday the list had many of my mkv files.
Today i have only mp4 and avi file.
What could it be?
I have encoded just 1 of my mkv files yesterday, so i shoud have all others.


#50

The list function hasn’t been modified and containers aren’t even looked at…weird. Why are you creating a new list anyway? If the media is the same, then why not continue processing your existing list?


#51

Because to make the test yesteday i stopped process after i few movies and manually modified list to have just the first movie to encode.


#52

Now this error after encode.

2018/11/23 10:37:30 NOTICE:
Transferred:        2.355G / 2.355 GBytes, 100%, 10.722 MBytes/s, ETA 0s
Errors:                 0
Checks:                 0 / 0, -
Transferred:            1 / 1, 100%
Elapsed time:     3m44.8s


File downloaded.

File codecs:
Audio = aac
Video = h264



An unknown error occurred with FFmpeg.
Trying with full conversion instead.


An unknown error occurred with FFmpeg.
Consider installing the custom build of FFmpeg via the install command.

#53

As suggested, that could be down to the standard build of FFmpeg. Try running the command with the --verbose flag set and post the results here?


#54

Here it is:
https://paste2.org/tpGOH9mJ


#55

Ah, subtitles. I should have known. That would definitely be due to the container change, I’ll need to do some research. There’s a chance that the custom build of FFmpeg could fix this, so I would very highly recommend doing that regardless as it has a better AAC encoder. Just run plexus install, 1, 2, 2 (this build usually takes 10+ minutes). Regardless, MKV should still direct play. When you get a chance, could you try playing it via Plex again and then send the screenshot of the Now Playing tab, please?


#56

Here it is, the problem is audio,

Immagine


#57

Ah, then the container certainly isn’t the problem. It’s unusual, but not unimaginable. AC3 is very common, but it could be transcoding due to channel count. I would try re-encoding using MKV as the container, then H264 and AC3 as the video and audio codecs respectively. You can just use -v and -a flags when running the encode command to achieve this (rather than running through the config process). Example: plexus encode -l list -r RCloneRemote -a ac3.


#58

I’ve just made new encode with AC3 audio and mkv container. Tonight i’ll try to play with my atv and let you know.

Just out of curiosity, if i have all info in plexus.conf why with command plexus encode do i have to specify -l and -r?

audio_codec=“ac3”
convert_dir="$HOME/.plexus/encode/convert"
converted_dir="$HOME/.plexus/encode/converted"
ffmpeg_binary="/usr/bin/ffmpeg"
ffmpeg_threads=“2”
ffmpeg_preset=“faster”
ffprobe_binary="/usr/bin/ffprobe"
force_overwrite=“false”
list_file="$HOME/.plexus/list.txt"
media_dir="/media/google_crypt/crypt"
mount_dir="/media/google_crypt"
rclone_binary="/usr/sbin/rclone"
rclone_cache=“YYY:”
rclone_remote=“XXX:”
video_codec=“h264”
video_library=“libx264”
media_container=“mkv”

And also for this you have to type -d even if it is set by default to a value

plexus list
Usage:
  plexus list -d /path/to/media [flags]

Flags:
  -a              Audio codec. Default = ac3
  -d              Media directory. Default = /media/google_crypt/crypt
  -l              List location. Default = /root/.plexus/list.txt
  -m              Mount path, used for RClone. Removed from the beginning of each list line
  -v              Video codec. Default = h264

#59

Just to let you know i’ve just read this post on plex forum.
This will change a lot about ATV


#60

Great :slight_smile:

Not everyone uses RClone for their storage. So the -r flag is to trigger the remote storage use rather than local storage. Indeed, if you are using the default list file location, then you don’t need to use the -l flag :slight_smile: The default remote is stored for mounting purposes, but this will probably change in the future.