Plex can't view encrpted files

What is the problem you are having with rclone?

Plex cannot see encrypted files

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.2

  • os/version: debian 11.7 (64 bit)
  • os/kernel: 5.10.0-22-amd64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Hetzner Storage Box

The command you were trying to run (eg rclone copy /tmp remote:tmp)

MOUNTING rclone mount remote:path/to/files /path/to/local/mount --vfs-cache-mode full --allow-non-empty
UPLOADING TO CLOUD rclone copy path/to/local cryptremote:/path --progress

The rclone config contents with secrets removed.

Editing existing "secret" remote with options:
- type: crypt
- remote: hetzner:/media/
- password: *** ENCRYPTED ***
filename_encryption = standard
directory_name_encryption = true

A log from the command with the -vv flag

I don't know how to get this information

Please post your rclone.config file content with secrets removed, you can get it by running:

rclone config show

and exact command you use for mounting.

type = sftp
host = removed
user = removed
pass = REMOVED
shell_type = unix
md5sum_command = none
sha1sum_command = none

type = crypt
remote = hetzner:/media/
password = removed

The code used fir mounting was in the 1st post

it is not exact command - I have no idea which remote you mount.

If Plex is running as the user 'plex' and you are mounting as a different user, you need to add


By default, fuse mounts are in the user space and only the user running rclone can see the files if I had to guess your problem.

Oh right! This makes sense.

Added user allow however it still doesnt show the encrypted files. It does show non encrypoted files. half way there

rclone mount hetzner:/media /home/krome/hetzner --vfs-cache-mode full --allow-non-empty --allow-other

change it to:

rclone mount secret: /home/krome/hetzner --vfs-cache-mode full --allow-non-empty --allow-other

1 Like

It Works, thank you

I would suggest to add:

--vfs-cache-max-size 100G to control max cache size

--cache-dir=/path/to/cache to control cache location

and maybe:

--sftp-concurrency=9 - hetzner allows max 10 connection as I remember

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.