Please Help, At a Loss About What Might Be Wrong Mounting Gdrive

What is the problem you are having with rclone?

I had rclone with gsuite drive mounted and running fine for a couple of weeks, after initial setups. I had to do a reboot today and while trying to get gdrive mounted again, the command appears to work but I don't see the drive as mounted at all in the file system. Please help, I'm sure being a linux newbie that this must be a basic issue that I'm somehow overlooking, and it's driving me crazy, especially since the initial setup was a breeze.

What is your rclone version (output from rclone version)

rclone v1.53.1

  • os/arch: linux/amd64
  • go version: go1.15

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu minimal 18.04.5 LTS (GNU/Linux 4.15.0-118-generic x86_64)

Which cloud storage system are you using? (eg Google Drive)

google gsuite drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount gcache: /home/oamayaz/mnt/google --dae                                                                                                             mon  --allow-other --cache-db-purge --allow-non-empty --buffer-size 32M --use-mm                                                                                                             ap --dir-cache-time 72h --drive-chunk-size 16M  --timeout 1h  --vfs-cache-mode m                                                                                                             inimal --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 1G &

The rclone config contents with secrets removed.

oamayaz@Plex-Media-Server:~$ rclone config show
type = drive
client_id = redacted
client_secret = redacted
scope = drive
token = redacted

type = cache
remote = google:/google
plex_url = redacted
plex_username = redacted
plex_password = redacted
chunk_size = 5M
info_age = 1d
chunk_total_size = 10G

A log from the command with the -vv flag

oamayaz@Plex-Media-Server:~$ rclone mount gcache: /home/oamayaz/mnt/google --dae                                                                                                             mon  --allow-other --cache-db-purge --allow-non-empty --buffer-size 32M --use-mm                                                                                                             ap --dir-cache-time 72h --drive-chunk-size 16M  --timeout 1h  --vfs-cache-mode m                                                                                                             inimal --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 1G -vv &
[1] 1350
oamayaz@Plex-Media-Server:~$ 2020/10/11 05:28:02 DEBUG : rclone: Version "v1.53.                                                                                                             1" starting with parameters ["rclone" "mount" "gcache:" "/home/oamayaz/mnt/googl                                                                                                             e" "--daemon" "--allow-other" "--cache-db-purge" "--allow-non-empty" "--buffer-s                                                                                                             ize" "32M" "--use-mmap" "--dir-cache-time" "72h" "--drive-chunk-size" "16M" "--t                                                                                                             imeout" "1h" "--vfs-cache-mode" "minimal" "--vfs-read-chunk-size" "128M" "--vfs-                                                                                                             read-chunk-size-limit" "1G" "-vv"]
2020/10/11 05:28:02 DEBUG : Creating backend with remote "gcache:"
2020/10/11 05:28:02 DEBUG : Using config file from "/home/oamayaz/.config/rclone                                                                                                             /rclone.conf"
2020/10/11 05:28:02 DEBUG : Creating backend with remote "google:/google"
2020/10/11 05:28:03 DEBUG : Google drive root 'google': root_folder_id = "0AI-dy                                                                                                             3M0VnPQUk9PVA" - save this in the config to speed up startup
2020/10/11 05:28:03 DEBUG : fs cache: renaming cache item "google:/google" to be                                                                                                              canonical "google:google"
2020/10/11 05:28:03 DEBUG : gcache: wrapped google:google at root
2020/10/11 05:28:03 DEBUG : gcache: Purging the DB
2020/10/11 05:28:03 INFO  : gcache: Cache DB path: /home/oamayaz/.cache/rclone/c                                                                                                             ache-backend/gcache.db
2020/10/11 05:28:03 INFO  : gcache: Cache chunk path: /home/oamayaz/.cache/rclon                                                                                                             e/cache-backend/gcache
2020/10/11 05:28:04 INFO  : gcache: Chunk Memory: true
2020/10/11 05:28:04 INFO  : gcache: Chunk Size: 5M
2020/10/11 05:28:04 INFO  : gcache: Chunk Total Size: 10G
2020/10/11 05:28:04 INFO  : gcache: Chunk Clean Interval: 1m0s
2020/10/11 05:28:04 INFO  : gcache: Workers: 4
2020/10/11 05:28:04 INFO  : gcache: File Age: 1d
2020/10/11 05:28:04 DEBUG : Adding path "cache/expire" to remote control registr                                                                                                             y
2020/10/11 05:28:04 DEBUG : Adding path "cache/stats" to remote control registry
2020/10/11 05:28:04 DEBUG : Adding path "cache/fetch" to remote control registry
2020/10/11 05:28:04 DEBUG : rclone: Version "v1.53.1" finishing with parameters                                                                                                              ["rclone" "mount" "gcache:" "/home/oamayaz/mnt/google" "--daemon" "--allow-other                                                                                                             " "--cache-db-purge" "--allow-non-empty" "--buffer-size" "32M" "--use-mmap" "--d                                                                                                             ir-cache-time" "72h" "--drive-chunk-size" "16M" "--timeout" "1h" "--vfs-cache-mo                                                                                                             de" "minimal" "--vfs-read-chunk-size" "128M" "--vfs-read-chunk-size-limit" "1G"                                                                                                              "-vv"]
2020/10/11 05:28:04 INFO  : plex: stopped Plex watcher
2020/10/11 05:28:04 DEBUG : Cache remote gcache:: Services stopped

Pastebin for easier reading:

You have some odd options in your mount command.

Start with something just vanilla and simple and do:

rclone mount gcache: /home/oamayaz/mnt/google

You should ditch the old cache backend and look at vfs-cache-mode full instead.

Make those changes and make sure you have no rclone running as with allow-empty and using --daemon, I'd guess you have multiple going and are over mounting.

First of all, let me thank you for taking a look at it.

I tried the command exactly as you proposed twice, both times on a fresh server reboot and still no dice. It seems like the command goes through successfully, yet still nothing shows up inside the folder. I should mention that I was indeed running into duplicate instances and the related message of "another rclone running" errors yesterday before I read some other treads where it was advised to kill instances, so I was doing either ps grep looks and kill commands or straight up rebooting between mount attempts. Not sure if it's relevant, but rclone functionality has been good otherwise, I have been doing copy and move commands successfully during all this mount downtime.

Could this be somehow related to the cache? Just spitballing here, but does it ever need to be "purged" or something along those lines?

Here is the output of the -vv flag during these attempts:

The log you shared looks normal as the mount has started and seems to be running fine.

What does:

ls -al /home/oamayaz/mnt/google 


oamayaz@Plex-Media-Server:~$ ls -al /home/oamayaz/mnt/google
2020/10/11 23:42:15 DEBUG : /: Attr:
2020/10/11 23:42:15 DEBUG : /: >Attr: attr=valid=1s ino=0 size=0 mode=drwxrwxr-x, err=<nil>
2020/10/11 23:42:15 DEBUG : /: ReadDirAll:
2020/10/11 23:42:15 DEBUG : /: >ReadDirAll: item=0, err=<nil>
total 0

This is what is shown with that.

I just got it to mount and show the proper gdrive content by rebooting server and mounting "google" which is the configured drive, but from the instructions I thought I'm supposed to mount the cache "gcache". Is this correct?

The cache backend is going to be deprecated and not recommended to be used. Please look at the vfs-cache-mode full which replaced it.

If you check:

rclone lsd google:

Based on your config, it's expecting to see a folder in there called "google".

So in your google: remote, you have folder called google, which are the contents you are caching (based on your config you shared).

Thanks for clarifying that, and your help and patience in general; I appreciate it.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.