Pi OS, Ownership of mounted Google Drive


What is the problem you are having with rclone?

The mounted Google Drive files and folders have as ownership root:root. But I need pi:pi. I am testing if Syncthing can distribute the mounted drive to the Computers of my Home network from my Pi. But Syncthing cant get access because of the ownership, I guess.

What is your rclone version (output from rclone version)


First of all welcome to the forums.
Secondly please try to follow protocol when joining a new community and asking for supports.
You know, there's a reason why they created a template for submitting supports threads.
Like for instance in this case: The command you were trying to run (eg rclone copy /tmp remote:tmp)

I bet you dont have UID & GID flag in your mount commands. But hey, we can only guess as you choose to exclude some vital information :slight_smile:

1 Like

hello and welcome to the forum,

try adding --allow-other.

i run rclone a pizero and pi4.
no need to run rclone as root, in fact, unless there is a specific reason, better not to.

Thank you very much. I thought I gave all the needed information. Nonetheless its not easy for me to wirte in english or read the protocol because english is not my mother language. I am really sorry if I did something wrong.

I was mounting like this:

cd ~
mkdir -p mnt/gdrive
rclone mount gdrive: $HOME/mnt/gdrive

I dont know what this is: UID & GID flag

Kind regards

try this
rclone mount gdrive: $HOME/mnt/gdrive --allow-other

Hi there, seems to be working. I had to add



Where can I find how to create a systemd for rclone in the kind of fashion to mount more than one gdrive at the autostart? Maybe a Dropbox too.

so you cannot run rclone mount without --allow-non-empty, what error did you get?

this is the goto guide for systemd, by a fellow rcloner.

I got this error message, when I just did this command **rclone mount gdrive: /mnt/gdrive --allow-other**

2021/03/29 19:54:42 Fatal error: Directory is not empty: /mnt/gdrive If you want to mount it anyway use: --allow-non-empty option

What do I have to change so that it is running on my raspberry? Nothing or what? Looks complicated to me: https://github.com/animosity22/homescripts/blob/master/systemd/rclone.service

well, you asked for about systemd and i shared the service file that the majority of rcloners use.

i am no linux expert, but i use that service file, never had a problem.

Yeah, I am a noob, who happens to know what systemd does and how to manage it. But such a long file looks complicated. Na, I will see next weekend about that.
Thank you very much you helped a lot.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.