Permission problems inside terminal (Google Drive)

What is the problem you are having with rclone?

I have just setup rclone with Google Drive and mounted my remote to my filesystem (~/drive). Some things work, like creating files and folders, even viewing images or editing files inside a text editor works. However when I want to edit a file inside the Terminal it doesn´t work at all. I can´t even view the file in nano/vim:
([ Path '.': Permission denied ])

What could be the reason for this behaviour?


rclone v1.61.1

  • os/version: debian bookworm/sid (64 bit)
  • os/kernel: 6.0.2-76060002-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.19.4
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

What I was trying:

sudo nano textfile.txt

permissions of the file:

-rwxrwxr-x 1 liam liam 0 Jan  4 11:09 textfile.txt

hello and welcome to the forum,

make sure to add --allow-other

and can you answer some of the questons in the help template, such as the exact command.

1 Like

That seems to have fixed it. Thank you!

My original command for mounting was

rclone mount "google-drive:" ./drive/ 

then I had to uncomment user_allow_other in the /etc/fuse.conf file.
Finally I ran this command:

rclone mount "google-drive:" ./drive/ --allow-other

sure, good this was an easy solution.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.