Permission Error with plex, Plex is not showing files of mounted drive

What is the problem you are having with rclone?

I have mounted my gdrive on my pc to use my movies in my gdrive as media to my plex media server which is running on this pc with linux mint as os. But the mounted folder contents are not appearing in the plex gui where we select libarary folders.

Run the command 'rclone version' and share the full output of the command.

rclone v1.59.1

  • os/version: linuxmint 21 (64 bit)
  • os/kernel: 5.15.0-46-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.18.5
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

Here is the output of ls -la

drwxrwxr-x 1 vasu vasu 0 Aug 28 21:46 .
drwxrwxr-x 1 vasu vasu 0 Aug 28 23:24 ..
drwxrwxr-x 1 vasu vasu 0 Apr 30 15:29 Anime
drwxrwxr-x 1 vasu vasu 0 Aug 28 21:45 Anime_Movies
drwxrwxr-x 1 vasu vasu 0 Apr 30 15:29 Movies
drwxrwxr-x 1 vasu vasu 0 Apr 30 15:29 Series
drwxrwxr-x 1 vasu vasu 0 Jun  2 20:43 Standup

The rclone config contents with secrets removed.

Current remotes:

Name                 Type
====                 ====
gdrive               drive

e) Edit existing remote
n) New remote
d) Delete remote
r) Rename remote
c) Copy remote
s) Set configuration password
q) Quit config

I have tried everything to change the folder owner to plex but unable to do so. Please Help

hello and welcome to the forum,

try adding --allow-other to the rclone mount command.

what is the exact rclone mount command?

I am getting an error with is command (Sorry I am a linux noob)

vasu@VJ-PC:~$ rclone mount gdrive: /home/vasu/gdrive --allow-other
2022/08/29 16:23:04 mount helper error: fusermount: option allow_other only allowed if 'user_allow_other' is set in /etc/fuse.conf
2022/08/29 16:23:04 Fatal error: failed to mount FUSE fs: fusermount: exit status 1

I Just want to mount my gdrive so my plex can acess contents of it without any permission issues. Can you help me with the right command?

Thanks for the help,
Looking forward to your reply

That's what you need to do if you want to have another process use the rclone mount (Plex in this case).

As root, edit that file and ensure that the line with user_allow_other is not commented out.

felix@gemini:~$ cat /etc/fuse.conf
# /etc/fuse.conf - Configuration file for Filesystem in Userspace (FUSE)

# Set the maximum number of FUSE mounts allowed to non-root users.
# The default is 1000.
#mount_max = 1000

# Allow non-root users to specify the allow_other or allow_root mount options.

That last line needs to not have a comment and that's all you need as the option you require is allow-other.

Just Can't Express my happiness in words. It works, finally!!!!! I wasted my 5 hours searching thoughout the web what is the issue and was about to give up when I found this forum as my last hope. Thanks alot, means alot to me. :hearts: :smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.