Permission deny on synology with google drive

What is the problem you are having with rclone?

I've tried to install rclone directly on DSM & use the docker "mumiehub/rclone-mount".
Both have the same error.

1, Create folder and input the folder name will show permission deny.
2, Can upload .txt(small size file) but all another file will failed, show space not enough.

Tried mount command :

rclone mount GoogleSharedDrives: /volume1/rclone/mount/test3 --vfs-cache-mode writes --allow-other --allow-non-empty --log-level DEBUG --log-file=/volume1/rclone/test2.log
rclone mount GoogleSharedDrives: /volume1/rclone/mount/test2 --allow-non-empty --allow-other --vfs-cache-mode off --dir-cache-time 672h --vfs-cache-max-age 675h --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 1G --buffer-size 32M
rclone mount GoogleSharedDrives: /volume1/rclone/mount/test2 --vfs-cache-mode writes --allow-other --allow-non-empty
rclone mount GoogleSharedDrives: /volume1/rclone/mount/test --allow-other --uid 1000 --gid 1000 --umask 022 --default-permissions --allow-non-empty --allow-other --buffer-size 32M --vfs-read-chunk-size=32M --vfs-read-chunk-size-limit 2048M --vfs-cache-mode writes --dir-cache-time 96h

Docker parameters :

docker run \
-d \
--name mumiehub-rclone-opencd \
--restart=always \
--cap-add SYS_ADMIN \
--device /dev/fuse \
--security-opt apparmor:unconfined \
-e RemotePath="Google:" \
-e MountCommands="--allow-other --uid 1000 --gid 1000 --umask 022 --default-permissions --allow-non-empty --allow-other --buffer-size 32M --vfs-read-chunk-size=32M --vfs-read-chunk-size-limit 2048M --vfs-cache-mode writes --dir-cache-time 96h" \
-v /volume1/docker/rclone/rclone_config:/config \
-v /volume1/rclone/mount/test2/:/mnt/mediaefs:shared \

Run the command 'rclone version' and share the full output of the command.

rclone v1.61.1

  • os/version: unknown
  • os/kernel: 3.10.108 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.19.4
  • go/linking: static
  • go/tags: none

DSM Version :
DSM 7.1.1-42962 Update 3

The rclone config contents with secrets removed.

type = drive
client_id = [HIDDEN]
client_secret = [HIDDEN]
scope = drive
token = {"access_token":"[HIDDEN]","token_type":"Bearer","refresh_token":"[HIDDEN]","expiry":"2023-02-21T00:03:16.531100564+08:00"}
team_drive = [HIDDEN]
root_folder_id =

Complete log on : log -

I've do 3 things for the log file.
1, Create a folder & name to "4". [Show permission deny, but the folder is created on GoogleDrive successfully.]
2, Upload a txt file : "Fortigate Config WOL.txt" [Success.]
3, Upload a .conf file : "AndrewHomeFW_7-2_1262_202302142054.conf" [Failed & click retry once.]

hello and welcome to the forum,
if you run rclone mount direct in terminal, no docker, no mumiehub, do you still have the problem?

I've tried to install rclone directly on DSM & use the docker "mumiehub/rclone-mount".
Both have the same error.

Does anyone have any idea ?
I've tried what I can try already, is it rclone is not compatible with DSM 7.1.1 ?

yes, from the terminal, rclone mount runs fine on DSM 7.1-42661 Update 3

fwiw, for testing, i would simplify things.
--- run rclone mount only from command line until all is working.
--- have the mountpoint, logs, caches, config, everything inside homedir
--- do not use --allow-non-empty
something like,

rclone mount GoogleSharedDrives: ~/rclone/mount/test3 --allow-other --log-level DEBUG --log-file=~/rclone/test2.log

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.