"Permission denied" error when trying to mount a remote

What is the problem you are having with rclone?

Can't Mount a remote because of this

mount helper error: fusermount: failed to open /dev/fuse: Permission denied
Fatal error: failed to mount FUSE fs: fusermount: exit status 1

on a Debian GNU/Linux 10 running on Android

Run the command 'rclone version' and share the full output of the command.

user@localhost:~$ rclone version
rclone v1.58.0
- os/version: debian 10.11 (64 bit)
- os/kernel: 4.14.190-perf-g767c9e1bf78e (aarch64)
- os/type: linux
- os/arch: arm64
- go/version: go1.17.8
- go/linking: static
- go/tags: none

The command you were trying to run (eg rclone copy /tmp remote:tmp)


A log from the command with the -vv flag

user@localhost:~$ rclone mount yacr: /folder -vv
2022/03/29 17:32:29 DEBUG : rclone: Version "v1.58.0" starting with parameters ["rclone" "mount" "yacr:" "/folder" "-vv"]
2022/03/29 17:32:29 DEBUG : Creating backend with remote "yacr:"
2022/03/29 17:32:29 DEBUG : Using config file from "/home/user/.config/rclone/rclone.conf"
2022/03/29 17:32:30 DEBUG : Creating backend with remote "YA:�������������� ����������"
2022/03/29 17:32:30 INFO  : Encrypted drive 'yacr:': poll-interval is not supported by this remote
2022/03/29 17:32:30 DEBUG : Encrypted drive 'yacr:': Mounting on "/folder"
2022/03/29 17:32:30 mount helper error: fusermount: failed to open /dev/fuse: Permission denied
2022/03/29 17:32:30 Fatal error: failed to mount FUSE fs: fusermount: exit status 1

Debian is running on Android phone (from app UserLAnd) and most of its settings broken, but I wanted to mount a rclone remote to upload files directly from Linux without moving them to a Windows computer.
Edit: I have no access to /dev folder and can't change it's permissions even with sudo

You need fuse installed to mount a fuse file system.

Not sure how to do that in your setup, but in Debian, it is generally:

apt install fuse

You didn't looked to that part where rclone couldn't open FUSE folder because it exists

and permission to that folder is denied, but anyways it was previously installed, maybe it was downloaded with older rclone version:

user@localhost:/data/data/tech.ula/files$ sudo apt install fuse
Reading package lists... Done
Building dependency tree       
Reading state information... Done
fuse is already the newest version (2.9.9-1+deb10u1).

I did see that but didn't think it was installed properly.

rclone doesn't install fuse as that's a separate install and won't install it.

If you can't access fuse, you can't mount.

felix@gemini:~$ ls -al /dev/fuse
crw-rw-rw- 1 root root 10, 229 Mar 29 15:26 /dev/fuse

If a regular user can't access it, you won't be able to mount.

I'd imagine it's related to that but I'm not familiar with that at all.

as far as i know, based on testing in the past.

to run rclone mount on android, need to root phone.
once rooted, than can rclone mount, using UserLAnd or termux.

there are many topics in the forum, and on the internet, about the need for root

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.