Permission Denied - Download Google Drive File

What is the problem you are having with rclone?

I am trying to download a file using RClone from a Python Script. I am able to use RClone to list a directory, so connection credentials should be valid. I get perrmission denied though I've verified that all files are publicly shared, visible, and downloadable from Drive manually.

I am wondering if the existence of spaces in file names is an issue that I'm not addressing properly. I do notice in the log below that it seems to be referencing a photo - I'm trying to download a Google spreadsheet as a csv file.

Any help appreciated.

What is your rclone version (output from rclone version)

rclone v1.36

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu - 64 bit - Dell T3500 -

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

'rclone -vv --dump-bodies copy "gdriveremote:/Sunnyside Times/SST Admin/Auto Updates/highlands_assn_officers" /home/don/devel/temp/'

Config File

type = drive
scope = drive
client_id =
client_secret =
token = {"access_token":"XXXX"}

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

1.36 is ancient. Can you upgrade to the stable and try again?

Thanks for the fast response.

I have upgraded to 1.49 and have the same problem. However, I have verified that I can download a file in another directory, so I clearly have a permission problem with Drive. I have checked that all directories in the path are accessible to anyone on the internet (not an acceptable permanent setting). Presumably this implies that I need more info in my config file??

Can you re-run it and share the -vv output?

It's in Pastebin:


What does:

rclone -vv ls "gdriveremote:/Sunnyside Times/SST Admin/Auto Updates/highlands_assn_officers"


b'2019/09/22 08:27:40 DEBUG : rclone: Version "v1.49.3" starting with parameters ["rclone" "-vv" "ls" "gdriveremote:/Sunnyside Times/SST Admin/Auto Updates/highlands_assn_officers"]\n2019/09/22 08:27:40 DEBUG : Using config file from "/home/don/.config/rclone/rclone.conf"\n2019/09/22 08:27:40 DEBUG : gdriveremote: Loaded invalid token from config file - ignoring\n2019/09/22 08:27:40 DEBUG : gdriveremote: Saved new token in config file\n2019/09/22 08:27:41 Failed to ls: directory not found\n'

What does:

rclone lsd gdriveremote:


I've also experienced this problem since 2-3 days ago
It seems like google limiting download (i'm using my own oauth)
[FILENAME]: Failed to copy: multpart copy: failed to open source: open file failed: googleapi: got HTTP response code 403 with body:

But when i'm uploading files, it worked normaly

This is my config that worked before i got the error

rclone mount "drive:/" "/opt/docker/drive/mount" \
--config "/home/torrent-worker/.config/rclone/rclone.conf" \
--cache-dir "/opt/docker/drive/cache" \
--vfs-cache-mode minimal \
--drive-v2-download-min-size 256M \
--vfs-read-chunk-size 128M \
--vfs-read-chunk-size-limit off \
--vfs-cache-max-size 100M \
--attr-timeout 10s \
--allow-other \
--umask 0 \
--uid "1000" \
--gid "1000" \
--user-agent 'Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36'

Can you start a new post and use the question template rather than hijack this thread? Thanks.

Sorry, missed your last response:

rclone lsd gdriveremote: ::

b' -1 2019-09-07 11:44:53 -1 2019-09-07-3D-Bust\n -1 2019-07-08 16:18:49 -1 3D Photos\n -1 2018-01-24 17:30:04 -1 Climate Studies\n -1 2017-04-12 11:37:53 -1 Geek Squad\n -1 2019-08-12 17:08:46 -1 JMU Collaboration\n -1 2019-07-01 16:45:08 -1 Meshroom\n -1 2019-09-22 04:39:05 -1 Personal\n -1 2018-09-09 12:26:09 -1 RCDC\n -1 2019-02-11 10:01:04 -1 RClone\n -1 2018-02-04 10:06:22 -1 Sunny Treasures\n -1 2019-09-22 07:37:13 -1 Sunnyside Times\n -1 2019-03-04 09:56:56 -1 Sunnyside Times Photos\n -1 2018-08-23 16:18:14 -1 Time Tracking\n -1 2019-06-02 17:09:28 -1 UpdraftPlus\n -1 2019-07-05 11:01:51 -1 rcdc\n'

You can use three back tics ` before and after something to enclose it as a code block like


Can you follow the directories down and till you get the path that does not work?

So add "gdriveremote:/Sunnyside Times" and run rclone ls -vv against it and so forth.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.