Performance issues mounting MEGA

What is the problem you are having with rclone?

After mounting my MEGA account on ubuntu linux, the up- and download speed is just around 1-2MB/s. Downloading the same test file via the installed MegaSync app, i reach around 10-20MB/s.

Mounting my Google-Drive to the same machine using the same parameters, the up- and download speed ist around 30MB/s.

Run the command 'rclone version' and share the full output of the command.

rclone v1.62.2

  • os/version: ubuntu 22.04 (64 bit)
  • os/kernel: 5.19.0-45-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.20.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount --allow-other --vfs-cache-mode full --vfs-cache-max-size 5000M google: /mnt/google-drive/ &
rclone mount --allow-other --vfs-cache-mode full --vfs-cache-max-size 5000M mega: /mnt/mega/ &

The rclone config contents with secrets removed.

type = drive
client_id = ****
client_secret = ******
scope = drive
token = *****

type = mega
user = ***
pass = ***

The go-mega library rclone is using is not the fastest.

There are two things you can try:

  1. Add --use-https to your mega remote config - Mega

  2. Add --bind IPv4 to your mount command - in case your ISP uses both IPv4 and IPv6 it is often reported that IPv4 is faster:

--bind string Local address to bind to for outgoing connections, IPv4, IPv6 or name

Thanks for your respone!
I changed my mount command like this:

rclone mount --allow-other --bind --vfs-cache-mode full --vfs-cache-max-size 5000M mega: /mnt/mega/ &

where is the local address of my ubuntu linux. I also added the --use-https option to the remote config, but the performance is same as before :frowning:

Because you write that the go-mega library is not the fastest: are there any alternatives?

I have no idea about any alternatives. If you search this forum for "mega speed" unfortunately you will see that it is old problem without any solution yet.

welcome to the forum,
can use megacmd to create a webdav server and have rclone use that.

I just installed and tested mega-cmd, the official command-line tool from MEGA. With the mega-get command i get around 20MB/s which is awsome! Does anybody know how complicated is it to integrate this into rclone?

The problem is, that i want to stream files from mega and i think that this won't work with via the webdav protocol.

create a remote like this

type = webdav
url =
vendor = other

rclone mount mega.webdav: ......

Thx, I'll give this a try!

Problem solved: after installing mega-cmd i started a webdav server with the "mega-webdav"-command. Now it was possible to create a new remote with type "webdav" (according to the description of @asdffdsa).
This new remote was mounted to a local folder with the rclone mount command. Now the down- und upload speed is around 20 MB/s :+1:
Thanks to @asdffdsa !!!

glad it worked out, nice and easy.....

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.