Passing backend flag to post API

What is the problem you are having with rclone?

I am unable to pass backend flag to REST API via POST

Run the command 'rclone version' and share the full output of the command.

rclone v1.61.1
- os/version: darwin 13.1 (64 bit)
- os/kernel: 22.2.0 (arm64)
- os/type: darwin
- os/arch: arm64
- go/version: go1.19.4
- go/linking: dynamic
- go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

I ran a server with command

rclone -vv rcd --rc-no-auth

I want to pass these flag via POST API like --drive-shared-with-me and --drive-root-folder-id


The best way to do this is using connection strings.

So use drive,shared_with_me: there are lots more examples in the docs

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.