Ownership/Perm Issue w/ Samba/Plex - gDrive

What is the problem you are having with rclone?

Can't access SMB shares (no permission)
Plex shows the shares greyed-out with a document icon. (can't open or add to library)

What is your rclone version (output from rclone version)

rclone v1.52.2-253-g71173605-beta

  • os/arch: linux/amd64
  • go version: go1.14.4

Also tested 1.52.2-250 beta previously.

Which OS you are using and how many bits (eg Windows 7, 64 bit)

unRAID 6.8.3 x64

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount -vv --allow-other --allow-non-empty --vfs-cache-mode=writes --dir-cache-time=72h --drive-chunk-size=32M --vfs-read-chunk-size=128M --buffer-size=256M --vfs-read-chunk-size-limit=off cs512td: /mnt/disks/gd
Note: This mount command had previously worked for several months, perfectly - not sure why all of a sudden I'm having issues. My previous version was old and didn't have the uid and gid spoofing options.
I have tried adding the flags
--uid=99 --gid=100 --umask=000
which sets the ownership to nobody/users - to match the ownership that is typically used in unraid for shares. These flags appear to indeed change the ownership to nobody/users according to the output of ls -l
I have also tried chown-ing and chmod-ing the parent directory to 99/100 to no avail.

The rclone mount works properly within the terminal as root, I can get directory listings, modify files, etc without issue.

I can also force the SMB mount to work if I include the following in the SMB conf file for the associated share:
force user = root
force group = root

Also, I can make Plex see the mount by running the docker as root (uid=gid=0).

These clues seem to indicate that there is an ownership problem but I'm not sure what else to try. I suspect this is likely an unraid issue rather than a rclone one but I'm hoping for any suggestions. I've posted at the unraid forums as well but I'm not sure there is a large enough base of rclone users there to get good visibility. I can't seem to find anyone else on the internet with a similar issue.

One more thing that might be relevant - I read somewhere that --allow-other depends on a similar flag in fuse.conf to be on. I've tried uncommenting the line in fuse.conf but I'm unsure if fuse must be restarted afterwards for the conf file to be processed. In unraid, fuse.conf exists in memory so my changes are not persistent after a reboot. Since everything was working until 3 days ago I doubt this matters.

Is there a sniffing software or something I could use to see what user the SMB share is expecting? I guess it's root since forcing root:root allows me to connect. I've run Samba at debug level 3 but I didn't see anything particularly interesting there.

The rclone config contents with secrets removed.

I don't think this is relevant considering that the mount is working properly under certain conditions.

A log from the command with the -vv flag

I don't see anything particularly interesting in the -vv output when failing to auth to the samba share. The log looks normal when the mount is used via the console.

rclone is a user space so by default only the user running it can see it.

You have to uncomment allow_other in the /etc/fuse.conf to make other users be able to see the files.

You can test that by having the user not running rclone see the files. If they can see the files, it's working.

You can't chown/chgrp/chmod anything on the rclone mount as it doesn't have a concept of that so they'd get reset back.

If you aren't sure what user or group mods you need, you can run with --umask 000 and it'll make the mount readable/writeable by everyone.

If you can validate with two users, that would eliminate any rclone permission items and you can take a look at smb after that.

1 Like

Note that I managed to break allow other in the beta briefly... It is fixed now

1 Like

Upon reinstalling the stable branch everything is as it should be. Should have tried this right off the bat. Many thanks!

1 Like

Thanks a bunch for your thoughts and troubleshooting ideas!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.