Overlapping remote problem on Dropbox

#1

Hi,

I’ve been following the (possibly outdated) recipe here to sync my laptop to Dropbox. The backup is set using:

#!/bin/bash
COMPUTER_NAME=$(hostname -s)
USER_NAME=$(whoami)
SOURCE_PATH=~/
DESTINATION_PATH=”dropbox:Backups/${COMPUTER_NAME}/${USER_NAME}”
ARCHIVE_DESTINATION_PATH=”dropbox:Backups/${COMPUTER_NAME}/${USER_NAME}_archive”

rclone sync $SOURCE_PATH $DESTINATION_PATH \
  --backup-dir $ARCHIVE_DESTINATION_PATH \
  --exclude-from exclude.txt \
  --delete-excluded

That gives the following error, which I can’t figure out.

2019/05/08 11:06:37 ERROR : Fatal error received - not attempting retries
2019/05/08 11:06:37 Failed to sync: can't sync or move files on overlapping remotes

It feels like this is something about avoiding recursive copying. Within my home directory, I do have a Cloud/ directory that currently links to my personal and work Dropbox accounts and my Google Drive, but I have that path in my excludes.

Any hints?

Many thanks,
David

OS: Mac 10.14.4
Rclone: rclone-v1.47.0-osx-amd64.zip

#2

Can you run with -vv and post the output? That will show what rclone received on the command line and from there it will probably be obvious what the problem is.

#3

Thanks - should have thought to look for verbosity flags. I get the following - nothing obvious to me leaps out!

2019/05/10 13:58:05 DEBUG : rclone: Version "v1.47.0" starting with parameters ["rclone" "sync" "-vv" "/Users/dorme/" "”dropbox:Backups/lb-dormelap/dorme”" "--backup-dir" "”dropbox:Backups/lb-dormelap/dorme_archive”" "--exclude-from" "exclude.txt" "--delete-excluded"]
2019/05/10 13:58:05 DEBUG : Using config file from "/Users/dorme/.config/rclone/rclone.conf"
2019/05/10 13:58:05 ERROR : Fatal error received - not attempting retries
2019/05/10 13:58:05 Failed to sync: can't sync or move files on overlapping remotes
#4

There appear to be some extra quotes in "”dropbox:Backups/lb-dormelap/dorme”" and "”dropbox:Backups/lb-dormelap/dorme_archive”" - I suspect those are causing the problem.

They look like smart quotes not the normal " but that may just be the forum - I’m not sure.

#5

Ack. Yup - that is it. I’d spotted that the recipe website had converted -- to en-dashes, but not the quote switching. Sorry!

#6

No worries! Which website did you get it off? Was it an rclone website?

#7

I just disabled that setting in the forum so it stops replacing quotes etc because it has caused problems before...

Cc: @Animosity022 @calisro

#8

I saw that you posted the URL above - sorry... Maybe leave a comment to say the dashes/quotes are wrong?