Operations/publiclink from dropbox error not autorized

What is the problem you are having with rclone?

Trying to get publiclink from a dropbox file. I can get the public link using the comand link, but it fails using the remote control api

What is your rclone version (output from rclone version)

rclone v1.57.0

  • os/version: Microsoft Windows 10 Pro 2009 (64 bit)
  • os/kernel: 10.0.19042.1288 (x86_64)
  • os/type: windows
  • os/arch: 386
  • go/version: go1.17.2
  • go/linking: dynamic
  • go/tags: cmount

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Microsoft Windows 10 Pro 2009 (64 bit)

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone rc operations/publiclink fs=dropboxpross: remote=versiones\readme.txt

The rclone config contents with secrets removed.

type = dropbox
token = {"access_token":XXXXX,"token_type":"bearer","refresh_token":XXXXXX,"expiry":"2021-11-07T22:07:31.8543954-03:00"}

A log from the command with the -vv flag

2021/11/07 18:50:03 DEBUG : rclone: Version "v1.57.0" starting with parameters ["rclone" "rc" "operations/publiclink" "fs=dropboxpross:" "remote=versiones\\readme.txt" "-vv"]
2021/11/07 18:50:03 DEBUG : 4 go routines active
2021/11/07 18:50:03 Failed to rc: Failed to read rc response: 500 Internal Server Error: {
	"error": "settings_error/not_authorized/...",
	"input": {
		"fs": "dropboxpross:",
		"remote": "versiones\\readme.txt"
	"path": "operations/publiclink",
	"status": 500

I'm running the server in the same pc:

rclone rcd --rc-no-auth

I've tried with rc-no-auth, and starting rclone rcd with --rc-user and --rc-pass but same result.

The issue seems only happens using rc command. Just the link command works ok, so with:

rclone link dropboxpross:versiones\readme.txt -vv

I get this:

2021/11/07 19:00:44 DEBUG : rclone: Version "v1.57.0" starting with parameters ["rclone" "link" "dropboxpross:versiones\\readme.txt" "-vv"]
2021/11/07 19:00:44 DEBUG : Creating backend with remote "dropboxpross:versiones\\readme.txt"
2021/11/07 19:00:44 DEBUG : Using config file from "C:\\Proy11\\sql\\Publicar\\rclone.conf"
2021/11/07 19:00:45 DEBUG : fs cache: adding new entry for parent of "dropboxpross:versiones\\readme.txt", "dropboxpross:versiones"
2021/11/07 19:00:45 DEBUG : Dropbox root 'versiones': attempting to share 'readme.txt' (absolute path: /versiones/readme.txt)
2021/11/07 19:00:45 DEBUG : /versiones/readme.txt: has a public link already, attempting to retrieve it
2021/11/07 19:00:45 DEBUG : 6 go routines active
2021/11/07 19:00:46 INFO  : Dropbox root 'versiones': Commiting uploads - please wait... 

Ant I get the link ok.

I don't know if its any setting aditional I'm missing or just a bug at the rc API. I've just tryied with http and json and get the same issue that with rc comand.

I don't use dropbox at all so not much I can offer here.

@ncw - thoughts?

1 Like

I think the backslash \ is the problem. Change it to a slash /. The command line interface does a bit of slash and backslash swapping but the API doesn't.

1 Like

Hi Nick.
Thanks for your response, but it doesn't wok.
I've changed the slash \ to / but get same error.
I tryed get a publiclink from dropbox root (no slashs), and doesn't work fom API, but works ok from command line.

I investigated more, that is a definitely a bug!

The problem is that the default of the expires parameter isn't being set properly and you can't pass in expires to a non-business dropbox without an auth error!

Try this

v1.58.0-beta.5860.742b01159.fix-dropbox on branch fix-dropbox (uploaded in 15-30 mins)

1 Like

Thanks very much. Now is working ok.

I've merged this to master now which means it will be in the latest beta in 15-30 minutes and released in v1.58

I'll probably put this in 1.57.1 if we decide to release that.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.