Operation not permitted when deleting file from remote

What is the problem you are having with rclone?

I have a mounted crypt remote that references a SFTP remote so files are encrypted on storage. When I try and remove a .partial file from a failed move I get "operation not permitted". I have ownership of the files, but can't delete them.

Run the command 'rclone version' and share the full output of the command.

rclone v1.65.2

  • os/version: ubuntu 23.10 (64 bit)
  • os/kernel: 6.5.0-17-generic (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.21.6
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

I am using a remote SFTP remote.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

sudo find . -type f -name *.partial -delete -print

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

type = sftp
host = XXX
pass = XXX
shell_type = unix
md5sum_command = md5sum
sha1sum_command = sha1sum

type = crypt
remote = hetzner00:/home/baldwin/files
password = XXX

A log from the command that you were trying to run with the -vv flag

This is the output from terminal.

find: cannot delete ‘./1923/Season 1/1923 - S01E03 - The War Has Come Home WEBDL-1080p.mkv.nuyoqoc4.partial’: Operation not permitted
find: cannot delete ‘./2 Broke Girls/Season 2/2 Broke Girls - S02E03 - And the Hold-Up WEBDL-1080p.mkv.kecomev3.partial’: Operation not permitted
find: cannot delete ‘./2 Broke Girls/Season 3/2 Broke Girls - S03E14 - And the Dumpster Sex WEBDL-1080p.mkv.hodabey5.partial’: Operation not permittedfind: cannot delete ‘./9-1-1/Season 1/S01E01 - Pilot WEBDL-1080p.mkv.qizafiq3.partial’: Operation not permitted

Are you mounting it?

The remote is mounted to a local folder. That's why I was hoping to use the find command.

I think I solved my own problem here. I found this post: Pass `find` results to `rclone delete` command - #4 by ncw.

I changed what I needed to on this and it worked. I had to run under sudo though. I don't understand why since the mount command says to use my user.

find ./ -name 'search_term*' -type f ! -newer /tmp/mytime | sed 's/^.\///' > filez
rclone delete --dry-run -files-from filez remote:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.