OpenDrive RClone mount stops working every few days

What is the problem you are having with rclone?

after a few days the mount point stops responding and to unlock it I have to kill the process and restart the mount.

What is your rclone version (output from rclone version)

1.52.2

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Ubuntu 18.04 LTS

Which cloud storage system are you using? (eg Google Drive)

OpenDrive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount OpenDrive: /media/OpenDrive/ --allow-other --allow-non-empty --buffer-size 64M --dir-cache-time 3h --drive-chunk-size 16M  --timeout 1h  --vfs-cache-mode full --vfs-read-chunk-size 128M --vfs-read-chunk-size-limit 1G

The rclone config contents with secrets removed.

[OpenDrive]
type = opendrive
username = ***
password = ***

A log from the command with the -vv flag

DEBUG : pacer: low level retry 1/10 (error Session does not exists, please re-login. (Error 401))
DEBUG : pacer: low level retry 2/10 (error Session does not exists, please re-login. (Error 401))
DEBUG : pacer: low level retry 3/10 (error Session does not exists, please re-login. (Error 401))
DEBUG : pacer: low level retry 4/10 (error Session does not exists, please re-login. (Error 401))
DEBUG : pacer: low level retry 5/10 (error Session does not exists, please re-login. (Error 401))
DEBUG : pacer: low level retry 6/10 (error Session does not exists, please re-login. (Error 401))
DEBUG : pacer: low level retry 7/10 (error Session does not exists, please re-login. (Error 401))
DEBUG : pacer: low level retry 8/10 (error Session does not exists, please re-login. (Error 401))
DEBUG : pacer: low level retry 9/10 (error Session does not exists, please re-login. (Error 401))
DEBUG : pacer: low level retry 10/10 (error Session does not exists, please re-login. (Error 401))
ERROR : /: Dir.Stat error: failed to get folder list: Session does not exists, please re-login. (Error 401)

That look like your session expired.

Is the failure preceded by a long period of inactivity?

Or is it after a fixed time?

This looks like something that needs fixing within rclone.

The problem occurs at a fixed time after 1/2 weeks from the start of the command. The maximum period of inactivity is 12 hours

Do you think if I made rclone log in again every 24h that would fix the problem? That would be easy to do.

The other alternative would be to wait for a 401 error, then relogin and retry the operation which would work quite well and doesn't have any arbitrary times in.

I can't find any docs on how long sessions are supposed to last - can you?

In the documentation (https://www.opendrive.com/wp-content/uploads/guides/OpenDrive_API_guide.pdf) I found the duration of the session only in the case of login via oauth2 (chapter 15); in this case the duration is 24 hours. From what I have seen from rclone behavior the session expires after about a week and a half.

One possible solution is to check if the session is valid with the /session/exists.json call (section 8.2) before performing the operations.

Thanks for the info.

I guess another option would be to switch to using oauth. I don't think OpenDrive did oauth when I made the backend but now it is a much more standard way of doing things.

That would save you having to have your password in the config file which is a win as far as I'm concerned.

The oauth auto-renewing of tokens is used by lots of other backends and is rock solid so it would fix this problem.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.