OneDrive to local destination (stuck)

I am getting input/output errors when trying to copy OneDrive to my local Linux machine. It did download 30 GB but got stuck and does not continue.

What is your rclone version (output from rclone version)

rclone v1.50.2

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone -vv --transfers 2 --tpslimit 299 copy '/root/OneDrive/' '/onedrive_local/'

The rclone config contents with secrets removed.

type = onedrive
token = {"access_token":"E=","token_type":"Bearer","refresh_token":"M"}
drive_id = 5927cd7a20529a1b
drive_type = personal

type = alias
remote = /onedrive_local/


2021/10/27 19:10:45 DEBUG : T/VMachine/w2.tgz: Reopening on read failure after 0 bytes: retry 2/10: read /root/OneDrive/T/VMachine/w2.tgz: input/output error

hello and welcome to the forum,

  • input/output error could be a network issue.
  • --tpslimit 299 seems to be a very high value, i suggest a value of 10.
  • best to update rclone to latest stable, v1.56.2 and test again.
  • it is recommended to use your own client id as per the documentation
  • without a full debug log, hard to know what is going on.


It looks like a copy from local (/root/OneDrive/) to local (/onedrive_local/).

Do you also have "rclone mount onedrive: /root/OneDrive" running?

If so, then why not do the copy directly: "rclone copy onedrive: /onedrive_local/" ?

I recommend you omit flags unless they are really needed and tested for the use case. Defaults are best for OneDrive in most situations. This also goes for --transfers (and clientID).

Fully agree.

Thanks for the quick feedback. Now with your suggestions it worked.

I mixed up by mounting OneDrive with Rclone and then using 'copy' on top.

I unmounted any rclone drives with 'killall -9 rclone'
I then updated to the lastest version with 'curl | sudo bash'
Then I confirmed the version with 'rclone version'
After I confirmed my config file was still there with 'rclone config show'
Then I started the process again using rclone -vv copy onedrive: '/onedrive_local/' and it works now.

I made a donation to Rclone. Thanks again.

1 Like


with onedrive, the one-time effort, which takes a few minutes, to create a clientid is not worth the long term gains?

No, I don't see a (significant) gain in my tests and therefore don't use it myself anymore.

I haven't seen a personal ClientID solve a slow/stuck OneDrive yet. It is my experience that most of these issues are due to simple misunderstandings or somebody shooting themselves in the food by adding parameters to increase --checkers, --transfers or similar.

ok, good to know.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.