OneDrive Student Config not working anymore?

My rclone startup batch file for my OneDrive stopped working, so I tried to reconfigure it.

I might be making a mistake on the last step, where I pick the account type:
Choose a number from below, or type in an existing value
1 / OneDrive Personal or Business
\ "onedrive"
2 / Root Sharepoint site
\ "sharepoint"
3 / Type in driveID
\ "driveid"
4 / Type in SiteID
\ "siteid"
5 / Search a Sharepoint site
\ "search"

I chose #1 here.
I get this error.
2020/04/03 16:13:13 Failed to query available drives: HTTP error 503 (503 Service Unavailable) returned body: "{\r\n "error": {\r\n "code": "serviceNotAvailable",\r\n "message": "Service unavailable",\r\n "innerError": {\r\n "request-id": "removedIDforprivacyhere",\r\n "date": "2020-04-03T20:13:12"\r\n }\r\n }\r\n}"

I removed the ID in the error code here^
Not sure if I'm doing something wrong or if Onedrive is crapping out now and needs new API updates for rclone or something.


Hello there!

Today my OneDrive Business also stopped working.
I can't seem to be able to renew the token. I mean, I can renew it but the "expiricy" is the current time/minute/seconds! I think that the token imediatly expires after beeing created...

Can someone confirm this?

@vladz0r - What version are you running as that seems old?

@xppx99 - best to start a new post and use the question template.

I grabbed the latest version, and also tried it on the version from 2-3 months ago. This OneDrive worked fine about a month ago.

Can you type rclone version and share the output?

rclone v1.51.0

  • os/arch: windows/amd64
  • go version: go1.13.7

And when you run rclone config, what are you picking?

I see onedrive and you can use the number or type in the words:

Storage> onedrive
** See help for onedrive backend at: **

Microsoft App Client Id
Leave blank normally.
Enter a string value. Press Enter for the default ("").

Which should lead to the next prompt.

I was writing out my entire process, and low and behold the setup just worked fine today. It must have been crapping out yesterday, because I did exactly the same procedure.

My procedure:
I just leave everything on blank or default, including that choice.
I've done the initial rclone setup fine before with Onedrive, and I'm used to doing the setup with with my Google Drive accounts as I've done it several times.

Key inputs:
rclone config
n (for new remote)
23 (for Microsoft Onedrive)
(no Microsoft App Client Id)
(no Microsoft App Client Secret)
n (no edit advanced config)
y (use auto config)
then it opens the site and I pick the account
1 (OneDrive Personal or Business)
0 (selected the OneDrive)

Goddamn I removed it and tried it on the other computer, but for that one it has an old rclone version. Now I can't get it to work on my first computer where it worked 10 minutes ago.
I don't want to have to reconfigure my rclone again so I haven't updated my version yet.

Rclone configs are preserved. Updates doesn’t modify/remove existing config

Back with a fresh new error.
2020/04/05 22:38:15 Failed to query root for drive (REDACTED): HTTP error 429 (429 ) returned body: "{\r\n "error": {\r\n "code": "activityLimitReached",\r\n "message": "The request has been throttled",\r\n "innerError": {\r\n "request-id": "(REDACTED)",\r\n "date": "2020-04-06T02:38:14"\r\n }\r\n }\r\n}"

Same problem. I get this error when I try rclone --vfs-cache-mode writes mount onedrive: ~/onedrive -vv.

2020/04/09 14:30:18 DEBUG : pacer: low level retry 1/10 (error Get!K...jKlL/root: dial tcp: lookup on read udp> i/o timeout)

It is not possible to repeat rclone config, either. It also quits with an error saying "Service unavailable".

Onedrive has throttled you because you reached your limits.

Best to start a new post rather than hijack this one and use the question template as you seem to have a local DNS issue by your error message.

Yet I've never even downloaded off of this drive :expressionless:
And I have upload space left. I don't really get it.

i just made Onedrive student config and it works fine except the speed is too much slow compared to previous month its in bytes

Have you found a solution for syncing it? I am having the same problem with my onedrive for students.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.