Onedrive - rclone mount not updating from remote, not quickly or not done?

STOP and READ USE THIS TEMPLATE NO EXCEPTIONS - By not using this, you waste your time, our time and really hate puppies. Please remove these two lines and that will confirm you have read them.

What is the problem you are having with rclone?

Run the command 'rclone version' and share the full output of the command.

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone mount njt145-onedrive:/myScripts $env:USERPROFILE/myScripts2 --vfs-cache-mode full

(using powershell)

The rclone config contents with secrets removed.

type = onedrive
token = {"access_token":"XXXXXXXXXX"}
drive_id = 00000000000000000
drive_type = personal

A log from the command with the -vv flag

i think this is the setting you need
"--poll-interval duration Time to wait between polling for changes. Must be smaller than dir-cache-time. Only on supported remotes. Set to 0 to disable (default 1m0s)"

and based on your debug log, it is working
023/05/25 16:22:09 DEBUG : : changeNotify: relativePath="test.txt", type=1

as test, i would try the following and document the current time when you do each upload.

  1. re-start the mount
  2. wait two minutes
  3. not using the mount, upload a file to njt145-onedrive
  4. wait two minutes
  5. repeat steps 3 and 4
  6. kill the mount
  7. post the debug output
1 Like

You are right :slight_smile:. After I used --poll-interval 0m1s it does sync at every second.
Now, my powershell code is this:

rclone mount njt145-onedrive:/myScripts $env:USERPROFILE/myScripts2 --vfs-cache-mode full --poll-interval 0m1s

Thanks for the help :slight_smile:

thanks for letting us know....

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.