Onedrive only updates the mount with a new change

What is the problem you are having with rclone?

I'm using OneDrive as a test instead of Google and the mount works without errors, however any change made to mount, the pool-interval update is only respected if another change happens afterwards. Example:
I created a file in the assembly and it appears locally but not in the cloud. In the tests, I was around 10min on hold and it doesn't show up. Then create another file and both appeared.

I was testing the creation and deletion of files on mount and the change is only actually made when a new change is made.

Run the command 'rclone version' and share the full output of the command.

rclone v1.63.1

  • os/version: debian 10.13 (64 bit)
  • os/kernel: 5.10.0-0.deb10.21-amd64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.20.6
  • go/linking: static
  • go/tags: none

Do not just type in a version number. Run the command and share the full output.

Are you on the latest version of rclone? You can validate by checking the version listed here: Rclone downloads

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

ExecStart=%h/bin/rclone mount onedrive-crypt: %h/Stuff/Onedrive \
  --poll-interval=10s \
  --tpslimit 5 \
  --tpslimit-burst 0 \
  --vfs-cache-mode full \

The rclone config contents with secrets removed.

type = crypt
remote = onedrive:Luiz_ilimitado/Luiz/
password = xe-XXXXXX
password2 = Tf-XXXXXX
filename_encoding = base32768

A log from the command with the -vv flag

Paste  log here

You would have to generate debug logfile and post here. Otherwise it is impossible to investigate anything.

Also try to remove poll-interval from your mount command. Default value is 1 min. Setting it to 10s might be too much.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.