OneDrive Office 365 version

Greeting All

When i select One drive option from the list, it takes me to OneDrive for Microsoft hotmail, l& outlook rather then office 365 version in order for me to authenticate.
How to get around this ?

I am new to linux & rclone please.

When you first posted, three was a great help template that collects a bit of information that you deleted so we have to go back and forth a bit.

What version are you running?
What OS are you running on?

hello and welcome to the forum,

office365 uses onedrive

 1 / OneDrive Personal or Business
   \ "onedrive"

Thank you for your reply, i did just that however it takes me to a page where i need to sign in to my Hotmail id rather then my Office 365 id this is the issue.


What if you opens the link printed after If your browser doesn't open automatically go to the following link: in your browser's InPrivate/Incognito mode?

I am sorry albertony i dont understand what you mean, sorry my English is not good.


No problem.
When you created the config, you used rclone config command? Then at the end you got something like this:

Remote config
Use auto config?
 * Say Y if not sure
 * Say N if you are working on a remote or headless machine
y) Yes (default)
n) No
If your browser doesn't open automatically go to the following link:
Log in and authorize rclone for access
Waiting for code...

Now, you say it opens your browser with wrong login?
What if you open a browser tab using your browser's private browsing feature, then copy paste the http://127.... link into the address field of that tab. Are you then able to login to the correct Office 365 account?

Yes i understand your point, i did what you said however it gives me the message below.
" That Microsoft account doesn't exist. Enter a different account or [get a new one] "
for office 368 the url that we goto is portal. office. com

i hope you get what i am trying to say.

I do, but I'm not sure I'm able to help you get further..

I noticed one thing, though: It seems the "interactive setup process" example is a bit outdated, but if you get into advanced config:

Edit advanced config? (y/n)
y) Yes
n) No (default)
y/n> y

Then you will eventually get to this option:

The type of the drive ( personal | business | documentLibrary )
Enter a string value. Press Enter for the default ("").

Does it make any difference if you choose "business" there?

I am not able to test it myself, because access to the Graph API has not been allowed by my company:

Need admin approval
rclone needs permission to access resources in your organisation that only an admin can grant. Please ask an admin to grant permission to this app before you can use it.

that is correct, you need to login to your office365 account

i did a test just now, works fine, this is what i see.
when i log using my onedrive business account, no problems.


If you want to share your rclone version output, that would make things helpful.

Sounds like you have old version, but you did not answer when I asked that before..

Yes and you were right i was using an older version seem this was recommended by my distro "elementary os" as being the supported version, anyways i upgraded my version and my issue got fixed, thank you everyone for helping me out, shukriya, merci, gracias shukran ...

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.