Onedrive gateway timeout error

What is the problem you are having with rclone?

It started with errors when running a sync command that it could not list the contents of a directory. So I tried just the lsf command to see if I could get something. It isn't working and it gives an UnknownError:. I tried decreasing the chunk-size and transfers to their lowest to get things to work but no luck. This post may be related, but I'm not sure and I couldn't find a resolution in that one either.

This isn't an especially large directory is has 842 files in it all told about 27 MB of data. It was working just two weeks ago. I don't know what may have changed. I am able to read/write lots of other files and directories on this same onedrive share without any problems. It is just a couple of directories that are giving me a problem. I kind of suspect that it could be a problem on the microsoft side of things, but I can't be sure. I can download these files through the onedrive web interface without any problems. So I'm stumped.

Run the command 'rclone version' and share the full output of the command.

rclone v1.59.2
- os/version: scientific 7.8 (64 bit)
- os/kernel: 3.10.0-1160.76.1.el7.x86_64 (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.18.6
- go/linking: static
- go/tags: none

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone lsf --transfers 1 --onedrive-chunk-size 320Ki "Cirrus-OneDrive:Battery_Data/Cirrus_data/UCCS/Q2_data_dump/Cirrus Q2 F1 Files/Data/PULSEData/P25/IFIX11_PULSE_P25_Z40/" --retries 1 --low-level-retries 2 -vv --dump bodies

The rclone config contents with secrets removed.

$ cat ~/.config/rclone/rclone.conf 
type = onedrive
drive_type = business
link_scope = organization
token = {"access_token":"...","token_type":"Bearer","refresh_token":"...","expiry":"..."}
drive_id = ...

A log from the command with the -vv flag

gist log

hello and welcome to the forum,

those flags should not affect rclone lsf, as that list files, does not transfer them,

and from that link you shared

so i think your command should have been
rclone lsf --onedrive-list-chunk, not rclone lsf --onedrive-chunk-size

as a test, i might create a new dir and copy the files into the new dir.
and then run rclone ls on that new dir.
and if that works, try rclone copy/sync

Thanks. Moving the list chunk down to 500 lets the lsf complete. I'm going to see if that flag will help the sync command.

I guess I didn't try that before because it didn't work in the other case. I have some hope now that this might fix it.

I gave those a try because the error message suggested them:

ERROR : UnknownError: : upload chunks may be taking too long - try reducing --onedrive-chunk-size or decreasing --transfers

Good to know that they aren't going to affect this particular operation.

yeah, that is most confusing.
at first, i also missed that. had to do a second read.

so, the rclone sync worked this time?

It is still running. It isn't the fastest thing ever. I'll report back as soon as it finishes (or doesn't).

After decreasing the --onedrive-list-chunk from its default of 1000 to 500. My lsf and sync operations successfully ran to completion.

all right, good to know,

in the end, tweaking --onedrive-list-chunk solved the UnknownError problem.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.