Onedrive for Business failed to save token


#1

I’m on stable rclone 1.45 and try to configure Onedrive for Business on a headless machine. So I authorize through a windows machine which also runs rclone 1.45 stable. Authorizing succeeds and I get a code which I should paste into the rclone terminal of my headless machine.

When I paste I get this error: ERROR : Failed to save new token in config file: section ‘Onedrive’ not found.
This one is new for me and this Onedrive did work a while ago.

Any ideas what’s going wrong?


#2

That is odd. I tried to replicate it but I couldn’t…

Have you tried copying the config file from the non-headless machine instead?


#3

Thanks for trying to replicate. I’ve tried to set up the mount on my Windows computer and that worked flawless. So then I tried it again on my headless machine and it still threw the error. However I could now choose for Onedrive for Business (amongst the choices like Sharepoint and such) and then choose the Onedrive I wanted mounted.

This last part didn’t work last time, but now I got a working mount. So problem solved itself, even with the error!


#5

I just tried the procedure with a new remote and I can see the same ERROR message - it is harmless thankfully, but a bit off-putting.

I’ve supressed the error in the latest beta (uploaded in 15-30 minutes) - thanks for reporting :smile:


#6

Cool, glad it’s not only on my side and you got it fixed! Thanks for the feedback.