OneDrive Client ID & Secret not working

yeah, now that you mention it, i did see that when i was setting up onedrive.
i just followed the rclone instructions - Microsoft OneDrive

if you think that those instruction are no longer correct, let me know,
we can create a new post, asking for an update

It says ...

Blockquote 1.
Enter a name for your app, choose account type Accounts in any organizational directory (Any Azure AD directory - Multitenant) and personal Microsoft accounts (e.g. Skype, Xbox), select Web in Redirect URI, then type (do not copy and paste) http://localhost:53682/ and click Register. Copy and keep the Application (client) ID under the app name for later use.

Accounts in any organizational directory (Any Azure AD directory - Multitenant) and personal Microsoft accounts (e.g. Skype, Xbox)
Updated rule is Starting November 9th, 2020 end users will no longer be able to grant consent to newly registered multitenant apps without verified publishers.

And/but you can choose between ...
**1||**Accounts in this organizational directory only (MSSVST only - Single tenant)|
**2||**Accounts in any organizational directory (Any Azure AD directory - Multitenant)|

(1) Doesn't work.

Edit: I'm exploring something really crazy ... I'll be back soon. I have to see if I am right.

Really funny,... what I thought of and wanted to try (I'm not sure, it did not work for me, but there are more possibilities based on that). So I will not try to explain it again, I have copied one part of thestigma explaination .

Maybe it is the same case at OneDrive?


So what was the problem? Well - it was ironically exactly what the error said, an API rate-limit .
The thing is, I had separate Oauth client IDs on several unrelated disks, so I was sure this was not an issue to even look into... but there was something I didn't realize until now: Oauth client IDs created inside of the same project apparently share quota - or at least share some form of burst quota. The solution was simply to recreate Oauth client IDs, each in their separate projects . I did this one by one with stress-testing in between and it was really obvious that the separate-project IDs had way more API quota at their disposal. Not only did they finish heavy list operations much much faster, but unlike the other drives they didn't get a lot of 403 rate-limit errors in their logs. As I moved more drives to separate-project IDs the pressure lessened on the remainder and I saw them speed up and get less errors.

Maybe anybody had the same situation? I can't belive that it me who has the only issue.

i like your forum name, kinda like mine,

i am human plus monkey -> jojothehumanmonkey
you are human plus, but what is the plus part?

Yes, you're right - very similar.

The "plus" is just "that little bit extra" :smiley: Nothing meaningfull.

Please take a look at my 1st screenshot, I don't have this point (this you clicked on).

Are you (XXXXXX) MP ID verified partner?

PS: It is on your screenshot! You should remove it

1 Like

thanks, my mistake.

yes, i noticed that. not sure why you do not see what i did.
are you using the rclone onedrive instructions, step by step?
using this link?

Yes, of course. There is only one application registration in Azure.

what about (2)?

To use multitenant the organisation has to be MP ID verified partner and gets, not sure a partner id, I don't know exactly.

as i mentioned, i did setup a onedrive account, based on a personal email address,, using a free account.
i am in the USA.

i just logged into it and started to register an application.
here is what i got

But I'd like to use my 5TB OneDrive.

my point is that i setup
a personal/free onedrive using a email address
i setup a paid/office365 onedrive with a domain name.

both times, i just followed the rclone onedrive instructions.

Just now registered an outlook.* mail address. Same issue. There is now option like yours.

good, making progress

what kind of onedrive is that?

It is a business account.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.