One drive: read: connection refused

What is the problem you are having with rclone?

I cannot create a remote One Drive with rclone.

Run the command 'rclone version' and share the full output of the command.

rclone v1.61.1

  • os/version: arch (64 bit)
  • os/kernel: 6.0.12-arch1-1 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.19.4
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

One Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config  


The rclone config contents with secrets removed.

nothing in rclone config. I unistalled and deleted all config using:

sudo rm /usr/bin/rclone
sudo rm /usr/local/share/man/man1/rclone.1

than, I used this sudo -v ; curl | sudo bash

A log from the command with the -vv flag

Looks like a normal firewall/antivirus/something blocking your connection.

Do you use IPV6? It's trying connect via that.

No, I think. How I can see if I am using?

The error is your machine tried to a DNS lookup and it failed.

2022/12/29 17:18:36 Fatal error: failed to get token: Post "": dial tcp: lookup on [::1]:53: read udp [::1]:42553->[::1]:53: read: connection refused

So either firewall blocking / DNS isn't setup, something is blocking it.

So.. I just try to reboot my machine and now I can config and mount. Sorry. Thanks for the your helping!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.