One drive mount is gone because of api limit

What is the problem you are having with rclone?

when i try mount one drive its disappears by itself. I know this information because when i wait a little bit its coming back.
tsplimit=1 is working for mount?
i have 64 gb ram. buffer chache is not important for me.
i just need a little bit help about that.

What is your rclone version (output from rclone version)

i am using lastest version.

Which cloud storage system are you using? (eg Google Drive)

one drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here

rclone mount --vfs-cache-mode full one:/ z: --network-mode

rclone mount 4:/ e: --vfs-cache-mode off --multi-thread-streams 30 --low-level-retries 2 --retries 2 --vfs-read-chunk-size 1M --drive-chunk-size 1M --buffer-size off --max-backlog 20000 --contimeout 7s --no-traverse --no-modtime --read-only -v --stats-one-line --stats 1m --network-mode

honestly i dont know well second command. i just make it for try but its failed too.
thank you.


  • onedrive is well known for api throttling.
  • need to be using latest stable v1.57.0, due to recent improvements with the onedrive backend.
  • need to see a debug log to know exactly what is going on. run this command and post the rclone.log file.
    rclone mount --vfs-cache-mode full one: z: --network-mode --log-level=DEBUG --log-file=rclone.log
  • once you post the rclone.log, perhaps @Ole can comment on it?

Thank you for fast answer.
i just wonder about that,
what can i do for leesest api request with mount issue.
honestly it takes hours of work to get a log access right now.

  • without the config file, hard to know if you have done this
  • some api quotas limits take up to 24 hours to reset.
  • what are you using the rclone mount for?
    rclone mount will use a lot more api calls than rclone copy/sync/move.
    so if you can, try to use rclone copy/sync/move when possible.
  • what does that mean, that the z: cannot no longer be found in windows explorer?
    as i mentioned, need a debug log to see exactly what is going on.

Hi etn_icin,

When I read your post I cannot see any connection between the mount disappearing/reappearing and an api limit. How did you determine this?

Is this related to your backup of 700TB Chia plots from Google Drive to OneDrive?

Hello again,
z: cannot no longer be found in windows explorer?
something like that. i take some screen shot for you.

@Ole no , thats not about that, thats just about mount.

i never saw something like this with google. i saw only one drive.

please help us to help you and post the requested info, instead of us having to keep trying to pull it from you. thanks

  • a config file, redact id/secret/token/password etc..
  • a full rclone debug log file.
  • the output of rclone version
  • the z: is listed in that screenshot, not understanding what this exactly means
    "when i try mount one drive its disappears by itself."

note: better to copy and paste text direct into the post, and not use screenshots for text.
enclose the text using three backticks so it looks like

rclone v1.57.0
- os/version: ubuntu 20.04 (64 bit)
- os/kernel: (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.17.2
- go/linking: static
- go/tags: none

I am not prof like you. I am a begineer user. I am afiraid i dont undersrand what kind of information do you need for helping me :frowning:
Please do not angry with me i just try my best.

sure, not angry just trying to be clear about the info we need from you.
no worries, let's do this one step at a time.

  1. run this command. copy and paste the text into a new post.
    rclone version

thank you.
its looking like that.

C:\Users\dortt\Downloads\rclone-v1.57.0-windows-amd64 (1)\rclone-v1.57.0-windows
-amd64>rclone version
rclone v1.57.0

  • os/version: Microsoft Windows 8.1 Single Language (64 bit)
  • os/kernel: 6.3.9600.20094 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.17.2
  • go/linking: dynamic
  • go/tags: cmount

please post the output of rclone config one:

make sure to delete any private info such as client_id, client_secret and token
should look like this

type = onedrive
client_id = 
client_secret = 
region = global
token = 
drive_type = business

never mind, here comes @ole

When responding to @asdffdsa then try to mark your output as code in the editor, like this:

This is marked as code and can hold a very long text in a terminal font  asdf kj hasd kjsakj asdkj asdfkj asdfkj asdfkj asd kfj 

This will make it much easier to read, when the output gets larger.

It is called "Preformatted text (Ctrl-E)"

i really wonder about ole's words. still replying.. :slight_smile:

rclone config test1cakmak: command is not working for me but i can find it on rclone.conf file.

type = onedrive
token = {"access_token":"xxxxx expiry":"2021-12-03T21:06:07.787152+03:00"}
drive_id =xxxxxxx
drive_type = business

thank you ole i will try that, i am greatful.

i wonder, you wonder, at time we all wonder :upside_down_face:

  • sorry, my mistake, command should have been this, but what you posted if ok for now.
    rclone config show test1cakmak:

  • what are you using the mount for? to play media files, to backup local files to onedrive or what?

  1. run this command
    rclone mount test1cakmak: z: --vfs-cache-mode full --log-mode=DEBUG --log-file=rclone.log
  2. try to re-create the issue/problem with the z: drive
  3. wait a full minutes and kill the rclone.exe.
  4. start a new post and upload the rclone.log file.
    click on the upload button image

i am using this mount for crypto mining :slight_smile:
but as i said i never saw like this problem with google.

anyway, this command save rclone.log file somewhere. where can i find this rclone.log file?
second question with me side,
3, i have to try mining in with this 1 minute?

by default, it is in the current working folder, whatever folder you can rclone from.
but you can locate the rclone.log file where ever you want.

I guess I failed again lol

C:\Users\dortt\Downloads\rclone-v1.57.0-windows-amd64 (1)\rclone-v1.57.0-windows
-amd64>rclone mount test1cakmak: z: --vfs-cache-mode full --log-mode=DEBUG --log
-file=C:\Users\dortt\Desktop\log\rclone.log --network-mode

Error: unknown flag: --log-mode

2021/12/03 21:41:03 Fatal error: unknown flag: --log-mode

damn, sorry, typing from my hellphone. i really miss my blackberry.
use --log-level

i really dont understand. i paste this command and its not give me an error message.
its not start mount.

rclone mount test1cakmak: z: --network-mode --vfs-cache-mode full --log-mode=DEBUG --log-file=C:\Users\dortt\Desktop\log\rclone.log

  • change --log-mode to --log-level
  • do not use --network-mode
  • make sure to delete C:\Users\dortt\Desktop\log\rclone.log before running rclone.