OBS and rclone (mkv)

What is the problem you are having with rclone?

Hey, I'm trying to have a way to save recording files from OBS to rclone, I tried different things but none of them have actually worked.

Run the command 'rclone version' and share the full output of the command.

rclone v1.60.1
- os/version: Microsoft Windows 10 Enterprise 20H2 (64 bit)
- os/kernel: 10.0.19042.631 (x86_64)
- os/type: windows
- os/arch: amd64
- go/version: go1.19.3
- go/linking: static
- go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)

Google Drive :slight_smile:

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone googledrivemountname z: --vfs-cache-mode full --cache-dir .vfs --vfs-cache-max-age 8h --network-mode --file-perms 0777 --dir-perms 0777

(I tried other commands but with no sucess)

The rclone config contents with secrets removed.

Just a basic rclone config with my api, and crypted google drive.

Basically I get an error saying OBS doesn't have the rights to write to the path (the rclone mount) because:

  1. There could be no space available
  1. No permission

Less important:
Other problem I encountered, was while creating and saving .mkv files they were getting corrupted (or at least they are playable but don't get the last bit of the mkv file that tells the "time" of the video file, basically an infinite mkv file)

what is OBS?

what are the current permissions?
might need to tweak permission from windows, not from rclone.
have to post the exact errors and if needed a screen snippet of the error from OBS

kill the mount, use a debug log, restart the mount, transfer a small .mkv and post the entire debug log.

Ok so:
OBS is https://obsproject.com/ (program used to record / stream)

I don't really know the current permission, I tried with the command "--file-perms 0777 --dir-perms 0777" and still got the error.

kill the mount, use a debug log, restart the mount, transfer a small .mkv and post the entire debug log.

Yeah but It doesn't happen when transfering a full complete mkv file, it only happens while it's beign written directly to the mount.

I'll send the screenshot later since I'm not at home right now.

check the windows folder/file permissions, not rclone permissions.

when you run rclone, the command prompt, are you running it in a standard privileges or elevated privileges.
make sure to use the same for OBS and rclone.
or use a folder, not drive letter, something like

rclone googledrivemountname: c:\path\to\mount --vfs-cache-mode full --cache-dir .vfs --vfs-cache-max-age 8h --file-perms 0777 --dir-perms 0777

Yes, that's is the main question, I think.

Unless execute permissions on files are relevant (which I think not, when just saving files from the application), this should not be any different from the default --file-perms 0666 --dir-perms 0777 and could be omitted. But related to that, I've found that with the default permissions, and when using the --file-perms/--dir-perms options, you get a set of ACLs that are a bit "messy", as it tries to emulate the corresponding Unix permissions. This may not be that useful for Windows users, and setting a specific ACL can give you "cleaner" permissions. E.g. -o FileSecurity="D:P(A;;FRFW;;;WD)" sets file read (FR) and file
write (FW) to everyone (WD), and nothing else. If file execute (FX) is also needed, then change
to -o FileSecurity="D:P(A;;FRFWFX;;;WD)", or if delete is needed then set all access (FA) with -o FileSecurity="D:P(A;;FA;;;WD)". There are some notes about this in the mount docs, and the beta version at tip.rclone.org contains even more. I don't see how this would solve @Magno's problem though, but might be worth a test after checking/answering @asdffdsa's questions...

1 Like

I run Windows on the Admin user, so everything is ran on high privilage.
I already tried to do it with a folder but got the same issue,

as admin user, by default, if i open a command prompt, it is not elevated.
and same for apps, have to explicit run as admin privileges.


might try running rclone mount as system user.

Mines open up as an administrator

Don't really know why...

ok and is running OBS running the same?

did you try to run rclone as system user?

I'll try different things now, thanks for helping

Tried with a completly new windows installation so that I would eliminate every variable that wasn't sure.
Still isn't working :confused:

At this point I don't really know what could be the problem, maybe it's how Winfsp mount the drive.

i mentioned this a few times, did you try?

why not save the files to local, and use rclone copy/sync/move to gdrive

Ok so I got around it by creating a RTMP server that I can stream on and saves the stream to my google drive.

But, the .mkv still is kinda corrupted, since every file is playable but it doesn't contain the last bit of the mkv file that tells "time"

why not save the files to local, and use rclone copy/sync/move to gdrive

Simply because if my video/stream is 24h long with a high bitrate I don't want to upload a 20gb file in one time, let's say I have a 6000 bitrate, that would just make 6mbs for 24h.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.