NSSM I forgot what the servicename is

What is the problem you are having with rclone? I can get rclone to mount my Gdrive but if I close cmd it takes away the mounted Z:Gdrive.

I tried using NSSM but I forgot what i used for the so now I can't remove it and start a new corrected one. I get an error from NSSM that reads: couldnt create service perhaps it is already installed.
I have tried deleting nssm.exe, ive tried the command line remove and every variation I thought I would have named it but no luck deleting the nssm service that I configured incorrectly.

What is your rclone version (output from rclone version)


Which cloud storage system are you using? Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

Paste command here

The rclone config contents with secrets removed.

Paste config here

A log from the command with the -vv flag

Paste  log here

hello and welcome to the forum,

these are some options to get a list of service names

  • command line sc queryex type=service state=all > service.list.txt
  • run services.msc

these are some ways to find a set of services that uses nssm.exe

  • system registry, search for nssm.exe under HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
  • powerhshell Get-WmiObject win32_service | Where PathName -match 'nssm.exe' | Format-Table -Wrap -AutoSize -Property Name,PathName

Nope, no nssm in that location

not sure what to tell you, perhaps on your system, there not a service using nssm or some other issue.

on my system, if i run that powershell script i created, it outputs

Name              PathName                     
----              --------                     
rclone.mount.zork d:\data\u\nssm\win64\nssm.exe

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.