NOTICE: Config file "/root/.config/rclone/rclone.conf" not found - using defaults

What is the problem you are having with rclone?

I just installed rclone and wanted to connect with google drive, but I am getting an error.
I tried 2 different setups, where I completely removed all old files. Always same output

What is your rclone version (output from rclone version)

rclone v1.57.0

  • os/version: debian 10.11 (64 bit)
  • os/kernel: 4.19.0-14-amd64 (x86_64)
  • os/type: linux
  • os/arch: amd64
  • go/version: go1.17.2
  • go/linking: static
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone config 
2021/11/11 11:53:13 NOTICE: Config file "/root/.config/rclone/rclone.conf" not found - using defaults No remotes found - make a new one 
n) New remote 
s) Set configuration password 
q) Quit config 
n/s/q> 2021/11/11 11:53:13 Failed to read line: EOF

then I am not able to "click" anything. I just get

root@root bin]# n 
sh: 1: n: not found

The rclone config contents with secrets removed.

Config file wasn't created

A log from the command with the -vv flag


Not quite following.

When you run rclone config, it generates some output on the screen:


As an example. What do you get?

So after I exectute the command I am not able to choose any option.

OK that is weird, rclone exited while waiting for you to press a character with the error Failed to read line: EOF.

The only way I can get that error is if I press CTRL-D at the prompt - did you do that?

Is there anything special/unusual about your terminal setup?

I am using the Webmin web-browser terminal, I know that some apps like 'htop' are not working so after you pointed me out I tested from normal SSH client - Putty and it worked. Thanks a lot!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.