Not syncing the files when edited on the other end (WebDAV - NextCloud)

What is the problem you are having with rclone?

I'm using it to map a WebDAV drive, and I can't get it to fetch the file on a refresh, it seems to use some kind of cache and it retrieves an old copy.
On the other end there is a nextcloud server, everything it's good until I edit the file inside nextcloud, never gets updated on the mapped drive unless I restart Rclone.

What is your rclone version (output from rclone version)

  • rclone v1.53.4
  • os/arch: windows/amd64
  • go version: go1.15.6

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10 LTSC x64 (1809 build 17763.1697)

Which cloud storage system are you using? (eg Google Drive)

Nextcloud 20.0.4

The command you were trying to run (eg rclone copy /tmp remote:tmp)

set "rclone_config_MYCONFIG_type=webdav" & rclone.exe mount MYCONFIG: J: --webdav-url=MYURL --webdav-vendor=nextcloud --webdav-user=MYUSER--webdav-pass=MYPASS --vfs-cache-mode=full --vfs-cache-max-age=1s --vfs-cache-poll-interval=1s --fuse-flag --VolumePrefix=\some\folder -vv

Note: the vfs cache parameters are just for testing purposes.

The rclone config contents with secrets removed.

I don't have, I'm running it as a single line command with all configs as parameters.

A log from the command with the -vv flag

GIST: /elalann/7d01c9987ad0c74375885dc999e18527
(I can't include links)

Thanks in advance to the community :slight_smile:

If rclone is getting a cached copy, wouldn't that be a nextcloud issue? or am I missing what you mean?

If you don't want caching then set --vfs-cache-mode to off

Or alternatively adjust this parameter so the entries fall out of the cache quicker.

  --dir-cache-time duration                Time to cache directory entries for. (default 5m0s)

At a first glance I thought that, but if I restart Rclone seconds after editing the file on nextcloud, it gets the latest version, so it makes me think I'm missing something on Rclone.

I'll try with --dir-cache-time and I'll give feedback to you guys.

Thanks very much!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.