Not able to connect to teamdrive

What is the problem you are having with rclone?

I've set up two teamdrives with rclone but i am not able to ls the remote or to mount it. Maybe i am doing it wrong.

Here is the rclone config
[TD]
type = drive
scope = drive
use_trash = false
skip_gdocs = false
skip_checksum_gphotos = false
trashed_only = false
allow_import_name_change = false
alternate_export = false
acknowledge_abuse = false
keep_revision_forever = false
server_side_across_configs = true
token = {
team_drive =
shared_with_me = true

[TD2]
type = drive
scope = drive
server_side_across_configs = true
token =
team_drive =
shared_with_me = true

What is your rclone version (output from rclone version)

rclone v1.51.0

  • os/arch: windows/amd64
  • go version: go1.13.7

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10 64bit

Which cloud storage system are you using? (eg Google Drive)

Google Drive / Teamdrive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

i've tried many commands like
rclone ls remote:TD
rclone ls TD://

but i am not sure how i have to use it properly.

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

2020/04/24 11:04:51 DEBUG : rclone: Version "v1.51.0" starting with parameters ["rclone" "-vv" "copy" "/tmp" "remote:tmp"]
2020/04/24 11:04:51 DEBUG : Using config file from "C:\Users\Seruschl\.config\rclone\rclone.conf"
2020/04/24 11:04:51 Failed to create file system for "remote:tmp": didn't find section in config file

I hope someone can halp me with this

Kind regards

The command should be rclone ls TD:. If that doesn't work, please attach the debug logs for it.

Thanks for this advice. The output for
rclone>rclone -vv copy /tmp TD:tmp is
2020/04/24 13:20:57 DEBUG : rclone: Version "v1.51.0" starting with parameters ["rclone" "-vv" "copy" "/tmp" "TD:tmp"]
2020/04/24 13:20:57 DEBUG : Using config file from "C:\Users\Seruschl\.config\rclone\rclone.conf"
2020/04/24 13:20:59 INFO : Google drive root 'tmp': Waiting for checks to finish
2020/04/24 13:20:59 INFO : Google drive root 'tmp': Waiting for transfers to finish
2020/04/24 13:20:59 INFO :
Transferred: 0 / 0 Bytes, -, 0 Bytes/s, ETA -
Elapsed time: 0.0s

2020/04/24 13:20:59 DEBUG : 5 go routines active
2020/04/24 13:20:59 DEBUG : rclone: Version "v1.51.0" finishing with parameters ["rclone" "-vv" "copy" "/tmp" "TD:tmp"]

I think i will delete the config and set all up again

So i've set all up again and it is still the same. I don't get any informations from GDrive.

I changed the name for the remote but when i try to list all with

rclone ls GDrive:

i get nothing in return

rclone 3

That connected and looks like you have no files in there as there are no errors.

Can you copy a file up or validate you can see things in the WebUI?

I have around 40GB on my GDrive and on the Teamdrive aroung 400GB and connecting via Browser is no problem.

Here is the result from copying.
https://pastebin.com/cgCXLGzX

It looks like it isn't able to list the directory.

The translation from the last sentence is:

Der angeforderte Name ist g├╝ltig, es wurden jedoch keine Daten des angeforderten Typs gefunden.
The requested name is valid, but no data of the requested type was found.

I think i've found the Problem.

It won't work when i set the "shared files" as true. So i guess rclone is havong issues to get the files which were shared with me.

Now it is working

Oh I missed that in your rclone.conf as you are correct.

If you have shared with me on, it only shows files that are shared with you. You'd have to make a separate remote for that I would surmise.

https://rclone.org/drive/#drive-shared-with-me

It makes sense that the shared files won't be visible when I set it up as Teamdrive. It is working by now so thanks for your help :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.