No sync between mounted drive and S3 Bucket

What is the problem you are having with rclone?

Hello guys
I managed to successfully mount my S3 bucket in Server 2019, I can see the data and I can create new
objects but I cannot see them in the bucket from the AWS console. If I create a new object in the bucket from the AWS console, I manage to see it in the mounted drive in the server. Looks like only one-way sync is working S3->Win but not Win->S3.
What could be the problem?

Run the command 'rclone version' and share the full output of the command.

rclone v1.60.0

  • os/version: Microsoft Windows Server 2019 Datacenter 1809 (64 bit)
  • os/kernel: 10.0.17763.3532 (x86_64)
  • os/type: windows
  • os/arch: amd64
  • go/version: go1.19.2
  • go/linking: static
  • go/tags: cmount

Which cloud storage system are you using? (eg Google Drive)


The command you were trying to run (eg rclone copy /tmp remote:tmp)

.\rclone mount *remotename*:*bucketname*/ E: --vfs-cache-mode full

The rclone config contents with secrets removed.

- type: s3
- provider: AWS
- access_key_id: 
- secret_access_key: 
- region: eu-west-1
- location_constraint: eu-west-1
- acl: bucket-owner-full-control
- storage_class: STANDARD

A log from the command with the -vv flag

Paste  log here

hello and welcome to the forum,

if you rclone copy a small text file from local to *remotename*:*bucketname*, does the file show in aws web gui?

think we need more info, can you do the following?

  1. can you post the exact bucket name, else create a bucket with a random name and use that.
  2. run .\rclone mount *remotename*:*bucketname* E: --vfs-cache-mode full --log-level=DEBUG --log-file=.\rclone.log
  3. copy a small file to E:\, let's call that file file.ext
  4. wait two minutes
  5. kill rclone mount command
  6. post the entire debug log.
  7. check if the file appears in aws web gui?

Thank you for your quick reply.
Following your suggestion, I tried to copy a file and it seems to work, now I understand that the issue I have is with folders sync and file sync works OK.
When I ran the test after the mounting procedure, I tested folder copy, not file copy.
Does it make sense?
Do you still need the logs?


so if you copy a folder from local to E:\, that folder does not appear in aws?

note: rclone cannot create an empty folder in s3, the folder needs to have files in it.
however, using the aws s3 website, s3 browser and many other tools, can create an empty folder.

Bingo! This is the explanation for the issue I have.
If I put a file in one of the folders in E drive it syncs along with the folder.
As you said, empty folders are not being synced.
Thank you very much.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.