No support for sha512crypt in htpasswd?

What is the problem you are having with rclone?

htpasswd file using sha512crypt does not seem to work. Is this expected?

Both lines are user:user

user:$2y$05$jQluYA6/Ztl.OePbnB6wm.0vBc1eJfKXPnHDMFBgZFsq32YzUKb2u
user2:$6$X5f/CrmBUsL.$OYvQULOiBs.1gXjmxmER2ngsZBbBaVVtxi9jKfHjwZCRf06B.qlAADuO8gNnDfRi7XXGFhuNhMAziavb/er.L1

I am perfectly well able to log in using user:user that is encoded using bcrypt but not the sha512crypt one. You can try for yourself using htpasswd contents as seen above.

What is your rclone version (output from rclone version)

rclone v1.53.3

  • os/arch: linux/amd64
  • go version: go1.15.5

Which OS you are using and how many bits (eg Windows 7, 64 bit)

RHEL8, x64_86

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone rcd --rc-web-gui --rc-web-gui-no-open-browser --rc-addr :8443 --rc-htpasswd /etc/htpasswd --rc-cert X --rc-key X -vv

A log from the command with the -vv flag

No useful otuput.

From the docs

Use --htpasswd /path/to/htpasswd to provide an htpasswd file. This is
in standard apache format and supports MD5, SHA1 and BCrypt for basic
authentication. Bcrypt is recommended.

This is provided by

So support for additional methods would need to go in there