No space left on the device - Rclone OpenWRT

What is the problem you are having with rclone?

I'm trying to use my OpenWRT, with a 2TB Hard disk attached, automatically sync my Google Drive files to it. When I try to do it, I get several errors of files that couldn't be copied with error message "No space left on the device".

My guess is that the internal storage of the device only has 120 MiB, and in some way, rclone is caching first the files into internal storage and then transferring (I tried some commands as shown below). I don't know if there is a way to fix this.

Run the command 'rclone version' and share the full output of the command.

rclone v1.59.1

  • os/version: openwrt 22.03.2
  • os/kernel: 5.10.146 (mips)
  • os/type: linux
  • os/arch: mips
  • go/version: go1.18.4
  • go/linking: dynamic
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync -P Gdrive:/ /mnt/sda1/GDRIVE
rclone sync -P --cache-chunk-no-memory --cache-dir /mnt/sda1/CACHE --cache-chunk-p
ath /mnt/sda1/CACHE-BACKEND Gdrive:/ /mnt/sda1/GDRIVE

The rclone config contents with secrets removed.

type = drive
client_id = removed
client_secret = removed
scope = drive
token = removed
team_drive =

A log from the command with the -vv flag


2022-11-01 03:12:47 ERROR : Otros documentos/CUENTAS.xlsx: Failed to copy: mkdir /mnt/sda1/GDRIVE/Otros documentos: no space left on device

Hard Drive was not properly mounted.


hello and welcome to the forum,

based on your config, these do nothing, are for the depracted cache remote.
rclone sync transfers files direct from local to gdrive, does not use additional local storage.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.