No Help Needed (yet) Just a Big Thank You

I wanted to say hello and pass on a big thank you to everyone in the rclone community and of course NCW.

Before last week I'd never even used the command prompt let alone rclone.

I've been using Amazon S3 for about 12 years and never had a problem uploading files to any of my buckets but last week that changed.

I'd not uploaded anything or even logged into my AWS console for a couple of weeks and during that time AWS did another "upgrade" to the management console.

That may just be a coincidence but since then I've not been able to upload a file any larger than 12Mb. I get a Network Error message.

I currently have paid for help through their support system but so far that has not solved my issue.


One of the items they requested from me to try and figure out a solution, was for me to use AWS CLI to upload the file and see if that works.

Long story short , I spend the next several hours learning how to use CLI and connect it to my AWS acct. The connection worked but the large file upload problem still exists.

I then found rclone and began reading posts here and watching a few vids and now am able to upload the large files to my Google drive account then copy to my S3 buckets.

So again, thank you.
Steve 'Happy-Camper' Dougherty

1 Like

Or you can upload to S3 directly if you want. Rclone don't have any size limitations.

Hi Harry,
I first tried the direct method using AWS CLI then did the rclone copy from drive to s3 then when that worked I figured why not give the rclone to s3 a shot.
No good.
The problem evidently is the connection from my end to s3.

I even have two different accounts with my ISP, which is only DSL, but the problem happens with both.
Again, that problem is brand new since I've had this same ISP for a few years and have been uploading to my S3 buckets for roughly 12 years and never had this problem.

Hopefully, the AWS Support staff will figure out the problem but until then I at least have rclone for the workaround.