No-check-certificate in config per remote possible?

What is the problem you are having with rclone?

Is there a way to use "no-check-certificate" functionality within the config and only for a specific remote not via command line or via env vars (like discussed here: Cannot validate certificate for Owncloud) .
For all other remotes the certificate check should still be conducted on normal use.

Run the command 'rclone version' and share the full output of the command.

rclone v1.66.0

  • os/version: darwin 14.4.1 (64 bit)
  • os/kernel: 23.4.0 (arm64)
  • os/type: darwin
  • os/arch: arm64 (ARMv8 compatible)
  • go/version: go1.22.1
  • go/linking: dynamic
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

webdav to a private owned NAS with WebDAV(s) support. Self-signed certificate.

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone lsd myWebDAVsNAS: --no-check-certificate

Please run 'rclone config redacted' and share the full output. If you get command not found, please make sure to update rclone.

Nothing special; Remote is working properly buts SSL certificate on server side is self-signed

A log from the command that you were trying to run with the -vv flag

If above command is used without --

...
 ERROR : : error listing: couldn't list files: Propfind "https:/<hided by me>/": tls: failed to verify certificate: x509: certificate is not valid for any names, but wanted to match <hided by me>
...

Failed to lsd with 2 errors: last error was: couldn't list files: Propfind "https://<hided by me>/": tls: failed to verify certificate: x509: certificate is not valid for any names, but wanted to match <hided by me>

Unfortunately, not currently.

You'd have to submit a PR for a config flag I'd imagine.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.