No_check_bucket = true config for all awss3, azure blob and GCS bucket access

Hello Experts,

We are trying to run rclone with machine identity (service account attached) based cloud bucket/container access.

And these service accounts attached have access to specific single bucket (no list bucket permission)
So for AWS S3 remote we rant into "Access Denied" error, but we are able to resolve it by adding "no_check_bucket = true" in remote (looks like below)

type = s3
secret_access_key =
access_key_id =
env_auth = true
provider = AWS
region = ap-south-1
no_check_bucket = true

Now we are looking to set same flag for Azure and GCS also, but when I try to create gcs or azureblob remote I dont see this flags in command line "config create" advance options.
(But I see --gcs-no-check-bucket and --azureblob-no-check-container in docs)

So can I add "no_check_bucket = true" to GCS remote and "no_check_container=true" to Azureblob remote ? will this skip the bucket list/create calls behind the scene ?

Note: Mainly I am looking for the options to set at remote config level instead of passing in file transfer operations request.

rclone v1.62.2


Yes. If it is in remote documentation it is valid option.

1 Like

Its called no_check_container on azureblob and no_check_bucket on google cloud storage.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.