Nextcloud and Rclone cache settings

Hello Guys
I currently use rclone together with nextcloud.
So rclone is mounted with google drive on the nextcloud /data directory so that the data is stored in Google Drive. Now I want data to be able to be uploaded to my server and from there to google.

Now I want data to be able to be uploaded to my server and from there to google. However, I would like to have a cache that the user does not have to wait because it takes longer because the data has to be uploaded to google.

So that the data is loaded onto my server, the process is completed and then to Google.
What are the correct cache settings in my case?

I am currently using: --allow-other --dir-perms 0770 --file-perms 0770 --uid=33 --umask 002 --attr-timeout 1000h --dir-cache-time 1000h --poll-interval=1m --allow-other --vfs-cache-mode full --vfs-read-chunk-size-limit 204800M

Can these settings be improved?

Thanks for help


never seen such a large value, what is the logic for that?
that flag is used when reading from gdrive, not for uploading to gdrive
imho, remove it

other than that, looks ok.

Oh, I thought it was also for uploading. Should I remove the value completely?
And with the other settings it works as far as I need it?

imho, use default values, unless you know what a flag does and why to tweak it.

that is up to you, tho i would remove it.

--allow-other, you have that twice?

once a file have been uploaded to gdrive, how long should the file stay in the local vfs file cache?

I think 48h is that possible?
Is it possible for the files to be uploaded to the server first and only a short time later to Google?

by default, five seconds after the file has been uploaded to the server, rclone will start to upload it to gdrive.

if you want to keep the files in the cache for 48 hours. then --vfs-cache-max-age=48h

Is there also a "variable" for this to change this setting?

yes, that is documented on the rclone mount webpage.

Okay, I'll look for him, thanks

This one:

--vfs-write-back duration                Time to writeback files after last use when using cache (default 5s)


yes, that is correct

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.