Newbie question - upload speed is very low

What is the problem you are having with rclone?

I've a 1G broadband connection that I am using to make a backup of NAS on a remote network file share. But I cannot get transfer speed more than 5-6Mbps. When I run speed tests, I am getting speeds of 950 Mbps consistently so not sure why rclone is running so slow.

Run the command 'rclone version' and share the full output of the command.

Which cloud storage system are you using? (eg Google Drive)

Backing up on another remote LAN using Fortinet VPN client and mounting the NFS using SMB (see config below)

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone copy /mnt/archives/synology/shadow_full.hbk/ /mnt/nfs_share/Mathur/testing/ --log-file ~/Downloads/testing/transfer.log -vv --progress --fast-list  --drive-chunk-size=1024M

The rclone config contents with secrets removed.

[transfer1]
type = smb
host = <redacted>
user = pm
pass = <redacted>

A log from the command with the -vv flag

https://pastebin.com/P8bY42cR

hello and welcome to the forum,

  • --drive-chunk-size=1024M, that is for gdrive, so can remove that.

  • from the rclone log snippet, rclone is working fine.

  • might increase --transfers and/or --checkers

  • have you tested without mount, without NFS?
    rclone copy /mnt/archives/synology/shadow_full.hbk transfer1: -vv

  • have you tested without rclone?
    on the source machine, create a smb mount and use cp ?

  • 950 Mbps - what kind of test did you run to get that value?

  • https://forum.rclone.org/t/smb-cifs-slower-than-regular-fstab-mounts/34537/1

Thanks, I have removed this.

yes the rclone is working fine but I'm trying to see if I can achieve better speed or if I am not using the options optimally.

I added "--transfers 25 --checkers 50" and the speed did increase a little bit (~1Mbps)

yes this one worked from the command line and the performance seems the same

I tried "pv oneBig_file > another_big_file" on SMB mount and still getting ~4Mbps transfer speeds

Few places like speedtest.com (ookla) and fast.com

Thanks for your insightful suggestions, I did learn a lot about rclone while doing these tests.

1 Like

me too.

so the copy operation speed remains the same, rclone or no rclone, correct?

Yes that is correct.

And here is some more context, the backup end point is the office LAN that is run by my friend. I am accessing the LAN via Fortinet client (VPN) and the speed tests were done after connecting the VPN client. The backup device is a Qnap NAS with RAID 5 configuration.

It is puzzling why the write speed (~5 Mbps) is slow on such a fast connection.

imho, seems to make sense.
your setup has additional paths/servers to traverse as compared to my test case below.

source: my windows 11 laptop - router: opnsense - 1000Mbps fiber optic internet
dest: smb share on windows 2019 server - watchguard T170 - 300Mbps fiber optic internet

i tested with two vpns, both had the same average speed - 12MBps
--- openvpn
--- tailscale

1 Like

Ok that makes sense and thanks for sharing!

you never posted output of rclone version?
are the source files stored on a synology box?

Here is the output of rclone version:

rclone v1.62.2
- os/version: ubuntu 22.04 (64 bit)
- os/kernel: 5.19.0-38-generic (x86_64)
- os/type: linux
- os/arch: amd64
- go/version: go1.20.2
- go/linking: static
- go/tags: none

The source files are the ones that I backed up earlier (from Synology) using Hyperbackup on home LAN,

fwiw, no sure your use-case but might simply that setup.
no smb, no nfs, no mount.
just a simple rclone copy direct the qnap sftp server.

could run rclone copy on your synology box, not use ubuntu as a middle-man.
on my synboxes, i use rclone copy veeam backup files to cloud.

check out my topic. i rclone copy to a synology sftp server.
https://forum.rclone.org/t/on-some-sftp-servers-e-g-synology-the-paths-are-different-for-ssh-and-sftp-so-the-hashes-cant-be-calculated-properly/36506/1

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.