New Feature: vfs-read-chunk-size


#82

Report back.

So the play back seems to be a mixed limitation of my TV and the player. Which after searching, is ongoing.

Sony XBR. Who the F%$!% puts a 100mbit NIC card in a 2017/2018 TV? Who?!?! Sony does! Who does NOT allow USB Gigabit cards to be installed? Who?!? Sony does! So i had to revert to the built in Wireless N. Wait you say that can be super fast? Yup, but it is attached to their USB2 connection limiting it to 200mbit. John Wick 2 Requires 180mbit to “stream” at near perfect speed/quality. without hiccups. Can the BUILT in DLNA player do that? Nope, stutters. Can installing PLEX from the APP store NATIVE to the OS do it? Nope, buffers.

Kodi + DLNA + Plex = Works 99%.

Anyways OFF topic.

What I am getting at, I am using your mount, no API Bans (never had that). No Download Quota Bans (Had that with NON Cache version). As apposed to CACHE versus VFS (yours). I feel the VFS plays faster/starts up faster/seeks faster. Can just be subjective though.

The fact that when the wifi is working good on Sonys end (sometimes wifi speed test nets me 30mbit…yes 30mbit (most of the time is 20-60) of the theoretical 300mbit I SHOULD be getting. Do a hard reset on the TV, run a test, get 200-300+. Run a second test, maybe 150-200. Don’t run anything. Wait 20-30 minutes. BAck to the 20-60. Wait 10 minutes run another test, get 150-200. Yup. TV is just 12 inches from the router. NO walls. a Glass/wood entertainment center. Router in shelf, TV on top. Yup.

Anyways back on topic again.

Your settings seem to be working just as good as Cache, just as good as Plexdrive OF the Cache, but has WRITE capabilities, which is AMAZEBALLS.

For whatever reason, when I used the CACHE version ON plex, it was writing the cache to a funky directory that I had NO CLUE where it was writing to. Maybe that was the point of the /tmp/drive. Either way, I am more than happy with this new mount. will keep testing.


#83

I choose that big buffer size in my last days of rclone cache testing.
If I choose Buffersize from 32-256 I have shuttering on 4k Streams.


#84

Odd. I run pretty high bitrate 4k streams and don’t stutter as this has been my current config:

/usr/bin/rclone mount gcrypt: /gmedia --allow-other --dir-cache-time 48h --vfs-cache-max-age 48h --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit 1G --buffer-size 16M --syslog --umask 002 --rc --log-level INFO

What’s your full mount command you are using?


Help with dir-cache, cache-info and uploads from outside the cache/mount
#85

I feel it is my new SONY tv.

Here is my mount:

rclone mount --default-permissions --allow-non-empty --allow-other --buffer-size 1G --dir-cache-time 12h --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit 2G gdrive-secure: /mnt/disks/gdrive-vfs &

just noticed I do not have “buffer size”.

However, Sony TV Native Plex APP = Okay Playability. If I use truillia and the “bandwidth” says anything > 80-90mbits/sec. I will encounter stuttering, especially if I have to transcode the audio from TRUEHD. (my transcode buffer though is 300 seconds, and the machine is always throttled). If I change the AUDIO to AC3 or whatever, and it DIRECT Streams/Direct Plays, I may or may not get stuttering with 80+mbit files.
However, if I play anything larger like John Wick 2, that requires 180mbit bandwitdh (since its 80mbit + data). It will stutter every 20ish seconds. Regardless of the audio selection.

Fix for that?

Use KODI + UPnP + DLNA. It will send the file “direct stream” with NO Stutter (maybe an occasional frame, like 1 frame, 1ms if that). Whether it is 80mbit file, or needs 180mbit bandwidth. So I feel it may or may not be the mount options. I feel it might be with PLEX the program, or how the TV “buffers” the data. It might be that PLEX native app tries to buffer the video on the TV and “fails” while DLNA buffers on the machine that is running the PLEX Media Center (Local Network). So maybe that --buiffer-size will force a larger buffer on the MOUNT regardless of where it is at. The “stops” are about 2-5 seconds, at the max rate the TV will download at that is about 5mbs ish. so maybe that buffer size is the solution unless I am thinking wrong.

I LOVE/Prefer Plex. Easy, Fast. Good UI. Shuffle. Chapter Selection.
Kodi + UPnP is literally just a FILE List. (Kodi + Library is SLIGHTLY better that is what I used to use, but I like (my wife likes) the Plex UI better.

Any ideas?


#86

What’s the specs on your plex server? Stuttering is not always rclone if your server can’t keep up CPU wise. Direct playing is much less load on the server.


#87

Okay not stutter, but 1-5 second pauses.

I would take stuttering as complete video playing, but with “choppy” frame rate.

“Buffering” would be pauses of 1-5 seconds before playing for 30 seconds then buffering again.

However, here are the specs.

Intel® Xeon® CPU E5-2630 v2 @ 2.60GHz

48 GB Multi-bit ECC

56TBs (about 27TBs free)

Unraid.

When transcoding, it is transcoded its full 300 seconds ahead and is “throttled” on the transcode.
It only needs to transcode AUDIO, video is DIRECT.

Think it could be the server? I don’t

The message I get is

“Your connection to the server is not fast enough”

I feel its 1) buffer
2) shit NIC card on the TV. causing #1 to happen much more often.

EDIT:

For example. Using PLEX turned the AUDIO to AC3 or whatever, so it direct plays. Just had 30 minutes of unbuffered/pauses. Then I will get one every 5 seconds for a total of 1-2 minutes (if i am lucky). This is due to the “speed” of the NIC cards, whether its built in or wifi.

I can put my laptop next to my TV and get my MAX speed wifi. the TV will get 1/10th of that speed. The router is 6 inches away, maybe 12.

Hard wired is even LESS on the TV.

So a mix of buffer and shit NIC on the TV.

EDIT2: Possibly the ExoPlayer v2. As Plex uses that, and Kodi does not.
This is android TV, so I do not know if it is that easy to change the default player.


#88

Yep. I think it’s more related to your setup. I’d remove rclone from the equation and play locally and see if you get the same problem. I’m all gig hard wired on ATV in my house so no issues with 4K playback.


#89

What device do you play through, reason i ask, is because the TV only has a 100mbit NIC card, I cannot make that faster! lol.

I am gig hardwired too everywhere. Just the TV has a 100mbit CARD! =-(

Maybe a new “device” that plays EVERYTHING.


#90

Would you say this is faster for starting files then your old config?


#91

ATV=4th Generation Apple TV for all my stuff with the 4K version for my main TV.

I would say everything starts much faster. I never noticed any stutters or buffering on either of my configs. Removing the cache just seems simpler for me.


#92

How do you continue to upload to gdrive without the cache? I’d like to try this out it it’s truly this much faster!


#93

I think I will try an Apple TV…

Does it do HDR 10bit?
Can it passthrough all AUDIO?

also how is the GUI? (does it have plex?) or do you play directly through ATV interface?


#94

I haven’t tried upload to drive without cache yet, just playback


#95

I just write directly to the mount as-is.


#96

Definitely does HDR 10 bit, but some audio gets transcoded. I don’t believe it passes through all audio.


#97

What happens if the data can’t be uploaded straight away if writing straight to the mount?


#98

I’d assume it would retry till it fails and than generate a write error if it couldn’t write.


#99

I see. It’d be great to use the cache part of uploading and storing files locally, but with this new method for accessing files on gdrive. It does seem about a second faster for loading for me.


#100

Is there an easy way to see the speed of files being uploaded using this new setup?

With the current cache system I have setup, files seem to upload very slowly so removing the cache would delay them being seen by Plex.

If anyone uses Sonarr, do you notice renames working correctly? Sonarr/Radarr (when using the copy feature instead of the default hardlink one) copy the file from Filename.filetype to Filename.filetype.partial~ initally and then renames it back, removing the .partial~ after the file is fully copied. Does anyone notice any problems with this using the vfs option?

How are the uploading speeds?


#101

That copy happens when Sonarr detects a different file system or it being moved onto a network share. It does a copy (as opposed to a move) to ensure the file isn’t corrupted by comparing the partial and the original, then deleting the original and removing the partial tag if the files match.

It really slows down the importing of episode if you’re moving onto the mount and can do direct moves (like with Usenet). Doesn’t seem to be any issue with Sonarr copying files onto the mount settings mentioned earlier in this thread (apart from the aforementioned issue).