Network users cannot write/modify after Google Drive Stream is mounted

What is the problem you are having with rclone?

Once the drive is mounted. Only the user that mounted it can write/modify the contents.
Tried NSSM, Task Sched, PSEXEC to run the mount as system, but the same issue, other users cannot write/modify the folder/file contents.
The need is to take a Google Drive Stream, mount it to a windows server, then anyone that uses the app on the server, can read/write/modify/create/delete files on that mounted share drive. Not just the one person that mounts the drive Using their gmail account)

What is your rclone version (output from rclone version)


Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows Server 2019

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

mount remote: T: --dir-perms=0777 --file-perms=0666 --vfs-cache-mode full -o --uid=65972 --config="D:\InmomentOps\Installs\rclone-v1.53.3-windows-amd64\rclone.conf" --allow-other

The rclone config contents with secrets removed.

type = drive
scope = drive
token = (access token removed)
team_drive = (drive value)
root_folder_id =

A log from the command with the -vv flag

Paste  log here

hello and welcome to the forum,

--allow-other does nothing on windows.

you want to net share a rclone mount over a lan?

what does google drive stream have to do with rclone mount?

Yes. I want to mount the share with full permissions and have an app running on the server, where it's mounted, see the mounted drive and have it look and act like a drive for all users hitting that server (not just the guy that created it).
What happens now is the drive is mounted and functions fine for my google user (the person that set up the mount). All other users see it, but can't write or modify the share drive contents.

here is what i do

  1. create a rclone mount mounted to a folder, such as b:\mount\rclone
    rclone mount wasabi01: b:\mount\rclone\wasabi01
  2. net share the b:\mount\rclone

Exactly We did that even using tools that load it as system (NSSN, PSEXEC). No matter how we do it. The drive lets the person who made it, full perms, but anyone else using it, read/delete/create, but not write or modify.
I think it's because the share content is only full access for that google account, not everyone who hits the drive. The users hitting the mount drive are not logging into the server. They are remote, running a client, that uses the local server drives to read write create edit modify delete etc. So the server drives C D etc work fine since they use domain permissions and are local to the server. But the google drive stream mount behaves differently.

well, that app, what user is it running as?

We did as you outlined. Mounted and shared a google drive stream drive/share on the server. It only gives full permissions to the person that set it up. Everyone else gets read/create/delete. Not modify or edit.

The app is running on the client as the users domain user account domain/user

not sure what google drive stream has to with rclone?

if that app is running as a domain user, then add that domain user to the net share permissions of the rclone mount

We are sharing a google drive stream share for the mount The files are on google drive and we are sharing them on the server (via mount) using rclone

if each user is running an app as a domain user, then add that domain user to the net share permissions of the rclone mount.

also, i have never used these flags
--dir-perms=0777 --file-perms=0666 -o --uid=65972

ok I can change the flags. We did mount the drive share the drive and try to give Everyone full perms It didnt work. It's grayed out and cant be modified on the mounted drive. Maybe do it via cmd?

you are running a rclone mount and that drive stream on the same computer at the same time?

Yes. We loaded the Google Drive Stream software on the server. Then we ran the rclone config.

are you using drive stream on the server?
have you tried to disable drive stream?

Yes we are, and no I have not. I will do so.

if you have the drive stream, then what do you need from rclone?
with drive stream, are you able to net share that over the network to that app?

The app sees the drive But it only works for the user that the gmail drive share belongs too. It acts as a local shared drive for just that user/account. We need the drive shared for anyone that uses that app/server. in the cloud..on a share we have files/folders we want those to be mounted to the server for the clients to use full perms so all the reading and writing and creating and deleting happen on the google share drive not the local server disks.

not sure what that is?

writing, that will always be on the local server vfs cache.
i think that for reading, also in the vfs cache

removed google drive from the server
used psexec to open a cmd as system user
execute rclone
rclone mount remote: T: --dir-perms=0777 --file-perms=0777 --vfs-cache-mode full -o --uid=65972 --config="C:\InmomentOps\rclone-v1.53.3-windows-amd64\rclone-v1.53.3-windows-amd64\rclone.conf"
the users can do everything BUT they CANT edit in place.... so close