Need help with Excluding folders

What is the problem you are having with rclone?

Hi,

We are having issues with backing up to Google Drive, everything works except the exclude for certain directories. As you can see below from the command, we are backing stuff up from H: drive, which is a mapped network drive. Within the root of that drive we have certain folders we would like to exclude (peoples names) for example "H:/Codie". It doesn't work for some reason, it still copies the directory. We are now trying the following option : --exclude "H:/Codie"/** instead of --exclude "H:/Codie/**" . there is alot of data, so it will take a while before I can see the results.

What is your rclone version (output from rclone version)

1.50

Which OS you are using and how many bits (eg Windows 7, 64 bit)

Windows 10 Pro 64bit

Which cloud storage system are you using? (eg Google Drive)

Google Drive

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone -P copy "H:" TBR:"/Work Drive 3" --exclude ShaderCache/** --exclude metadata/** --exclude *.info --exclude *.bin --exclude *.meta --exclude .git/** --exclude "!BUILDS/**" --exclude "!Git/**" --exclude "!Unity/**" --exclude "H:/Codie/**" --exclude "H:/Jade/**" --exclude "H:/Jennifer/**" --exclude "H:/Joao Backup/**" --exclude "H:/Allan/**" --exclude "H:/Craig/**" --exclude "H:/Damian/**" --exclude "H:/Devon/**" --exclude "H:/Gerard Stuff/**" --exclude "H:/Johnny/**" --exclude "H:/Marc/**" --exclude "H:/Michael/**" --exclude "H:/Michael von B/**" --exclude "H:/Mickey/**" --exclude "H:/Oli/**" --exclude "H:/Peter/**" --exclude "H:/Philip/**" --exclude "H:/Quinton/**" --exclude "H:/Reder/**" --exclude "H:/Shane/**" --exclude "H:/Stella/**" --exclude "H:/stellla/**" --exclude "H:/Stephan/**" --exclude "H:/Stephan's_Compendiums/**" --exclude "H:/Tanya/**" --exclude "H:/Thato/**" --exclude "H:/Tiffany/**" --exclude "H:/Timothy/**" --exclude "H:/Tyrone's_Modest_Collection_of_models_he_borrowed/**"
Pause

A log from the command with the -vv flag (eg output from rclone -vv copy /tmp remote:tmp)

n/a

These want to be --exclude "/Codie/**" which means exclude a directory called Codieand everything beneath it (the/**) at the root of the transfer (the initial /`)

You can use rclone ls with the same filters - that will show you very quickly whether the files are included or not.

Ah okay, so no need to put int he drive letter again, I will try this and report back. Thanks

1 Like

This is the solution, thanks it is working now :slight_smile:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.