NAS Backup question

What is the problem you are having with rclone?

Cloning a (local) Archive hard drive to my (local) NAS and encrypt that with help of rclone. I get an error while performing the task which says: "permission denied."

The NAS drive is mounted via SMB, but I fear I need to insert my NAS' username and password probably in the config file too? If so, how can I do that?

Run the command 'rclone version' and share the full output of the command.

rclone v1.58.0

  • os/version: darwin 11.6.5 (64 bit)
  • os/kernel: 20.6.0 (x86_64)
  • os/type: darwin
  • os/arch: amd64
  • go/version: go1.17.8
  • go/linking: dynamic
  • go/tags: none

Which cloud storage system are you using? (eg Google Drive)

Local NAS by QNAP mounted via SMB

The command you were trying to run (eg rclone copy /tmp remote:tmp)

rclone sync -P -u /Volumes/Archive/ nas-encrypted:/New/ --transfers=4 --create-empty-src-dirs --backup-dir=nas-encrypted:/Backup/ --rc

The rclone config contents with secrets removed.

type = alias
remote = /Volumes/Archive\ \(NAS\ Backup\)/

type = crypt
remote = nas:/Volumes/Archive\ \(NAS\ Backup\)/Crypt/
filename_encryption = off
directory_name_encryption = false
password =
password2 =

A log from the command with the -vv flag

I don't quite know how to do that, but I am getting this error message per file in Terminal:

2022-04-30 20:12:36 ERROR : Archive Folder/Software/Essentials/Logic Failed to copy: mkdir /Volumes/Archive\ \(NAS\ Backup\): permission denied

I love rclone, would love to hear your thoughts how I can solve this issue. It's probably very easy, but I am just stuck. Many thanks in advance!

hello and welcome to the forum,

rclone, just like any other program, need permission to access files/dirs.
so from that same command prompt, should be able to mkdir that same dir from the error.

instead of using smb, can use sftp.
qnap should be able to function as a sftp server.
then create a sftp remote for rclone.

Wow thanks so much for the quick answer! I just tried, but have problems accessing my NAS via rclone. I allowed SSH connections via port 22.
Then I set up "sftp" via the config file, inserted the NAS' IP, inserted my NAS' admin username in "SSH username" and when rclone asked me to generate/leave blank/type own password, I type my NAS' admin password. For all subsequential setup questions I used the default answers.

However, when trying to find out, if I set this up correctly with

rclone ls "or" rclone lsf

I do get a huge file tree of invisible files (which seems to be the QNAP's Linux file tree, surprisingly there are BitTornado-files which I never installed there), but I do not see the volumes. This is possibly more QNAP-support-related, but if you or anyone else here has experiences setting up QNAP or similar Linux-based NAS-systems via SFTP, I would be very happy about any hints what I could do better here.


If that's interesting, I attach the file tree (and leave out alle the weird BitTornado files which are not useful here)

        5 .bash_history
      175 .bash_logout
      161 .bash_profile
     1687 .bashrc
       36 .buzzer_warnning.conf
       27 .profile
      923 .vimrc
     6526 index_default.html
     2602 .ssh/id_rsa
      569 .ssh/
     1381 .ssh/ssh_host_dsa_key
      605 .ssh/
     2602 .ssh/ssh_host_rsa_key
      569 .ssh/
      188 .ssh/sshd_config
       17 .ssh/sshd_user_config
        0 .BitTornado/.LicenseCenter.lck

can you post the redacted output of rclone config show remote:
change remote: to the name of your remote


type = sftp
host =
user = admin
pass = *** ENCRYPTED ***

I think the issue is how you have it set up.


type = alias
remote = /Volumes/Archive\ \(NAS\ Backup\)/

type = crypt
remote = nas:/Volumes/Archive\ \(NAS\ Backup\)/Crypt/
filename_encryption = off
directory_name_encryption = false
password =
password2 =

when you go to nas-encrypted: you are going to nas:/Volumes/Archive\ \(NAS\ Backup\)/Crypt/ which is going to /Volumes/Archive\ \(NAS\ Backup\)/Volumes/Archive\ \(NAS\ Backup\)/Crypt/

Try instead

remote = nas:Crypt/

Thank you, I fixed that, but that doesn't solve the problem with the permission. I'm still trying to figure this out, if anyone has an idea, I'd be so happy.

need to post the updated config file.

and it would be best to test with a simple command such as rclone mkdir.
post the full debug output.

I was able to get a connection via SFTP. I initially had the problem only seeing the linux file tree and not my shared folders. So for everyone having the same problem with a QNAP NAS, here's the solution, that worked for me:

With the IP via SFTP set up in the config file, lsf/ls only shows the linux file tree without shared folders. When you set the IP/share/ in your config file, this probably gives you an error. The solution for me was, to leave the blank IP in the config file and then build the correct path in the command line, i.e.

rclone sync -P -u /Volumes/Archive/ nas-encrypted:/share/Archive\ \(NAS\ Backup\)/

So apparently the share folder was not visible in the file tree, but you could access it like that.

Hope that helps.

Couldn't figure out how to do this via afp/smb though as there remains the permission problem.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.