Multiple drives mounted with a single service?

no such concept.

just one remote and just one drive letter per command.
no duplicates
as per my examples

start rclone remote1: x: and then add the flags/arguments.

ColdStorage: what is the backend provider?

They are both google drive.

so with the attached arguments I should not have the gdrive: p: and coldstorage: s: parts because it's at the beginning..

yes, that is correct.

start rclone gdrive p: --allow-other --dir-cache-time 72h --drive-chunk-size 64M --log-level INFO --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit off --config "C:\Users\sli4.config\rclone\rclone.conf" --vfs-cache-mode writes

start rclone ColdStorage: s: --allow-other --dir-cache-time 72h --drive-chunk-size 64M --log-level INFO --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit off --config "C:\Users\sli4.config\rclone\rclone.conf" --vfs-cache-mode writes

so this?
Since i will be using this bat file instead of rclone.exe in the path field, do i need to change rclone to show the location and exe (start c:\rclone\rclone.exe)?

let's get the batch file working and then deal with nssm, ok?

looks good, give it a try

if I run it as admin it says it can't find rclone and i should check the path is correct does not give me the error or do anything if i run it normally.

where is the rclone.exe located?
let's say is is c:\path\to\rclone
add it to the command like so

start c:\path\to\rclone\rclone

a cmd window blinks now and nothing happens.

post the command

start f:\rclone\rclone gdrive p: --allow-other --dir-cache-time 72h --drive-chunk-size 64M --log-level INFO --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit off --config "C:\Users\sli4.config\rclone\rclone.conf" --vfs-cache-mode writes

start f:\rclone\rclone ColdStorage: s: --allow-other --dir-cache-time 72h --drive-chunk-size 64M --log-level INFO --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit off --config "C:\Users\sli4.config\rclone\rclone.conf" --vfs-cache-mode writes

did the mounts appear?

add this to the commands

no. Instead of getting the error like before, it just blinks a cmd window and then nothing mounted/nothing else happened.

i'll add that and try.

add this to the commands

and let's do just one command, not both.

same blink. no mount
start f:\rclone\rclone gdrive p: -vv --allow-other --dir-cache-time 72h --drive-chunk-size 64M --log-level INFO --vfs-read-chunk-size 32M --vfs-read-chunk-size-limit off --config "C:\Users\sli4.config\rclone\rclone.conf" --vfs-cache-mode writes

always works for me.
change --log-level INFO to --log-level DEBUG

and the blink is just fine


and the command line, are you running it with admin privileges or standard?

tried changing log level to debug

i've tried it with and without admin access.
here's my admin window output:


C:\Windows\system32>start f:\rclone\rclone gdrive p: -vv --allow-other --dir-cac
he-time 72h --drive-chunk-size 64M --log-level DEBUG--vfs-read-chunk-size 32M --
vfs-read-chunk-size-limit off --config "C:\Users\sli4.config\rclone\rclone.conf"
--vfs-cache-mode writes

really, not sure what to tell you.
i run mounts every day, just as i shared with you.

with nssm, what username do you run the rclone mount as?
a local user or system user?

I use the admin user account which i believe is local.
..according to the user profile it is local.

sorry, i really have nothing more to offer.
i run mounts every day on multiple machines, no problems.

i mean no disrespect, your problem is lack of experience with basic batch scripts and command line. not to do with rclone itself.

just create a nssm service for each mount.

you had it working for with nssm,
so create another nssm service for each mount.

No disrespect or offense taken - at all. I recognize I know pretty much nothing about batch scripts and command line.

I appreciate you taking the time to work this through with me. It's unfortunate we could not figure it out.